default dir for printing (Feature #63)


Added by Pieter Van den Hombergh about 10 years ago. Updated over 9 years ago.


Status:Closed Start date:06/06/2012
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:1.2.0

Description

My practice is to store all files relevant for exam production in one directory tree, including the pdf produced by printing to file. I use 'copies' as name for this subdir. as in ~/MC-Projects/lnx_20120629/copies.

It would be nice to have this option (a project relative directory) in the destination directories list.


History

Updated by Alexis Bienvenüe almost 10 years ago

From revision r1130, if you choose a subdirectory of the project directory when printing to files (for example ~/MC-Projects/lnx_20120629/copies), next time you print to files, the directory will be adapted to the project you print from (from project lny_2012, the default directory to print to will be ~/MC-Projects/lny_2012/copies). Is this suitable for your purpose?

  • Status changed from New to Feedback

Updated by Pieter Van den Hombergh almost 10 years ago

Hello again,
Course and exam season has started again.

I (svn) updated and created the deb package, installed that, such that I now run svn revision 1133.

I observe no difference in behaviour from how I printed last time, but maybe I am not looking properly.
In the previous version (last used in July) I could already specify a printing directory.
Is this option now saved in the project options.xml file or is the relative directory name saved (or suggested from) elsewhere?

Updated by Alexis Bienvenüe almost 10 years ago

Yes, this path is saved in options.xml, as it already was. But now, the directory ~/MC-Projects/lnx_20120629/copies used in project lnx_20120629 is saved as %PROJECT/copies, so that when you use printing from another project, the path is adapted.

Updated by Pieter Van den Hombergh almost 10 years ago

Looks like a very compatible change then.
At the moment I made my MC-Projects-tree a bit deeper: I use the academic year (2012-2013) as an extra level.
In what options.xml file should I look to verify the saved choice?

Updated by Pieter Van den Hombergh almost 10 years ago

Could that be in

 ~/.AMC.d/cf.default.xml

Updated by Pieter Van den Hombergh almost 10 years ago

Confirmed.
Works ad advertised.
Nice work and thank you very much again.

Updated by Alexis Bienvenüe almost 10 years ago

Pieter Van den Hombergh wrote:

Could that be in
~/.AMC.d/cf.default.xml

Oh yes I made a mistake, and you discovored the right place the path is stored!

  • Status changed from Feedback to Resolved

Updated by Alexis Bienvenüe over 9 years ago

  • Target version set to 1.2.0
  • % Done changed from 0 to 100
  • Status changed from Resolved to Closed

Also available in: Atom PDF