AMC-gui.pl does not start in 1.0.977, ubuntu 10.04 lts (Bug #46)


Added by Pieter Van den Hombergh over 8 years ago. Updated about 8 years ago.


Status:WontFix Start date:04/05/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-

Description

Built system using make deb.
Then installed with

sudo dpkg -i /tmp/auto-multiple-choice_1.0.977-1_i386.deb

starting auto-multiple-choice fails with error:

Gtk-WARNING **: Unknown property: GtkImage.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkImage.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkImage.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkButton.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkComboBox.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkButton.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkButton.valign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkHBox.valign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkButton.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkButton.valign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkButton.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkButton.valign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkHBox.hexpand at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkScrolledWindow.hexpand at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkTreeView.halign at /usr/lib/AMC/AMC-gui.pl line 715.
Gtk-WARNING **: Unknown property: GtkTreeView.hexpand at /usr/lib/AMC/AMC-gui.pl line 715.
Unknown internal child: selection at /usr/lib/AMC/AMC-gui.pl line 715.

The warnings also occur under ubuntu 11.10, but the Unknown internal child is only with ubuntu 10.04


History

Updated by Alexis Bienvenüe over 8 years ago

Yes, I confirm this bug... I'm trying to see what is missing in Ubuntu 10.04, and to find a workaround.

  • Subject changed from AMC-gui.pl does not start in 1.0.977, ubunto 10.04 lts to AMC-gui.pl does not start in 1.0.977, ubuntu 10.04 lts

Updated by Alexis Bienvenüe over 8 years ago

I'm afraid the only solution is to read, correct and write (and sometimes build from zero) all glade files with an old glade version (<=3.8), which seems to be quite a lot of time...
If you have other ideas, or if you want to do the job, please tell me.
Else, I think the "solution" is to wait and upgrade to Ubuntu 12.04 (or upgrade to Ubuntu >= 11.04).

Updated by Pieter Van den Hombergh over 8 years ago

Since I have a ubuntu 11.10 machine available and 12.04 is around the corner, I'll settle for one of those versions.

So I will run my production on the 11.10 machine for now.

Updated by Alexis Bienvenüe about 8 years ago

  • Status changed from New to WontFix

Also available in: Atom PDF