LuaLaTeX 0.85 and newer need AMC update (Bug #423)


Added by Davide G.M. Salvetti almost 6 years ago. Updated about 4 years ago.


Status:Closed Start date:08/25/2016
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:LaTeX
Target version:1.4.0

Description

Since LuaLaTeX 0.85 (or maybe 0.87) almost all pdfTeX extented primitives with names \pdf have been renamed or removed (see: http://tug.ctan.org/macros/generic/luatex85/luatex85.pdf).

When running LuaLaTeX AMC therefore needs to use \savepos instead of \pdfsavepos, etc.


History

Updated by Alexis Bienvenüe over 5 years ago

  • Description changed from Since LuaLaTeX 0.85 (or maybe 0.87) almost all pdfTeX extented primitives ... to Since LuaLaTeX 0.85 (or maybe 0.87) almost all pdfTeX extented primitives ... More

Updated by Tarik Graba over 4 years ago

I can confirm this bug.
On Debian stretch (stagble) with LuaTeX, Version 0.95.0 (TeX Live 2016/Debian) and AMC 1.3.0.

As workaround, I had to define the missing commands by adding the following:

\let\pdfsavepos\savepos
\let\pdflastxpos\lastxpos
\let\pdflastypos\lastypos

before the \usepackage[...]{automultiplechoice}

Tarik

Updated by Alexis Bienvenüe over 4 years ago

This should be corrected with revision hg:8953b594f329.

  • Status changed from New to Resolved
  • Target version set to 1.4.0
  • % Done changed from 0 to 100

Updated by Alexis Bienvenüe over 4 years ago

Applied in changeset hg:8953b594f329.

Updated by Alexis Bienvenüe about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF