Unexpected exit of AMC (Bug #176)


Added by Anirvan Sarkar over 9 years ago. Updated over 9 years ago.


Status:Closed Start date:05/19/2013
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:1.2.1

Description

After the creation of a new project, say testproject, when AMC is exited a Dialog Box opens which says:

You did not save project testproject options, which have been modified: do you want to save them before leaving?

Screenshot of Save Options window

AMC abruptly exits when the close button on the title bar of dialog box is clicked. If the close button is clicked AMC should not exit.


save-options.png - Screenshot of Save Options window (72.8 kB) Anirvan Sarkar, 05/19/2013 10:23 am

AMC-DEBUG-4iU6rCUA.log (49.5 kB) Anirvan Sarkar, 05/19/2013 10:27 am


History

Updated by Alexis Bienvenüe over 9 years ago

Applied in changeset r1385.

  • % Done changed from 0 to 100
  • Status changed from New to Resolved

Updated by Anirvan Sarkar over 9 years ago

It works properly if AMC is exited through Project>Quit.
But on clicking the close button on the Title bar, AMC still exits if the dialog window asking for saving options is closed without any response.

Updated by Anirvan Sarkar over 9 years ago

Maybe this will be helpful.

Updated by Alexis Bienvenüe over 9 years ago

Revision r1385 fixes the bug for me. Can you double-check you installed this version?
Then , try the following code from a terminal:

perl -le 'use Gtk2 -init;print  Gtk2::MessageDialog->new(undef,"destroy-with-parent","question","yes-no","Please answer")->run;'

Destroy this dialog window and tell me what is returned in the terminal.

  • Status changed from Resolved to Feedback

Updated by Anirvan Sarkar over 9 years ago

Alexis Bienvenüe wrote:

Can you double-check you installed this version?

AMC is the latest version - svn:1385
OS is Ubuntu 12.10.

Then , try the following code from a terminal:
[...]
Destroy this dialog window and tell me what is returned in the terminal.

delete-event

Updated by Alexis Bienvenüe over 9 years ago

delete-event

Same result as with my setup.
So I can't reproduce the bug and don't see what's going on...
Maybe I will try a Ubuntu 12.10 virtualbox.

  • Status changed from Feedback to New

Updated by Anirvan Sarkar over 9 years ago

Anirvan Sarkar wrote:

But on clicking the close button on the Title bar, AMC still exits if the dialog window asking for saving options is closed without any response.

I have now noticed that AMC does not exit but it runs in the background. But the main GUI window of AMC closes which apparently makes it look like AMC has exited.

P.S. The process name of AMC in the System Monitor is listed as perl. I only noticed it because it had the AMC logo in front of it. It will be helpful if the name is something intuitive such as auto-multiple-choice.

Updated by Alexis Bienvenüe over 9 years ago

Any progress with revision r1389?

Updated by Anirvan Sarkar over 9 years ago

Alexis Bienvenüe wrote:

Any progress with revision r1389?

Yes, the problem is solved. It now works as intended.

Updated by Alexis Bienvenüe over 9 years ago

Good. Thanks!

  • Target version set to 1.2.1
  • Status changed from New to Closed

Also available in: Atom PDF