New error message when "updating documents" in AMC

Added by Clayton Spencer about 1 month ago

I'm now getting the following error message when I attempt to "update documents" on the preparation tab after loading a .tex source file. The error message in the "command output details" is:

This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/Debian) (preloaded format=pdflatex)
I can't find the format file `pdflatex.fmt'!
Output format: pdf

This is a new error for me. I recently tried to install a tex package to add chemistry related formatting. This involved installing a new version of texlive (2018). I think that installation has now caused problems with AMC but I don't know how to fix it or undo the changes made with the new texlive install.

I use texstudio to write the latex input files. It also can't use pdflatex to generate a processed latex pdf file for sample viewing. I changed the options in texstudio to point to the pdflatex executable in the texlive/2018 directory: /usr/share/texlive/2018/bin/x86_64-linux/pdflatex. I no longer got the pdflatex error with texstudio but it gave a new error about not being able to find 'automultiplechoice.sty'.

Advice on how to fix this issue? I have exams that I can't mark because AMC can't reload the scoring information from the latex file.

Thanks, in advance, for your help.


Replies (1)

RE: New error message when "updating documents" in AMC - Added by Alexis Bienvenüe about 1 month ago

it gave a new error about not being able to find 'automultiplechoice.sty'

Your TexLive 2018 has to be aware of this file. Maybe copy it to some location inside /usr/share/texlive/2018/, along with pther packages, and run texhash?

This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/Debian) (preloaded format=pdflatex)

Note that debian testing has TexLive 2019.

(1-1/1)