Strange behavior in development version

Added by S. McKay over 5 years ago

I installed the development version on OS X Sierra using the instructions on the website.
I have been testing it and have run into some puzzling behavior. I hope someone can check and verify on their system.

Again, this is the development version.
After I create a project and create the exams, and after I scan the exams and run them through AMC
When I select Mark, it processes the files but claims that there are no marks afterwards. When I look at marks, I can see that some scores are not 0 but the averages are all claimed to be 0. If I shut down AMC, and then restart it and reload the project, the marks are correctly displayed (where it says Mean: xxxxx).
This is also happening with student identification. If I set the student list file, I can select the primary key, but I cannot select the code name. After I have shut down and restarted, the code name properly appears in the drop down box.

It's like some things are not getting updated properly except when the project is loaded. I can work around it, but its a bit annoying, and was confusing to me when I first started testing the development version.

Is anyone seeing this? I can attach a test file if you want.

Replies (4)

RE: Strange behavior in development version - Added by Joël Brogniart over 5 years ago

I notice the same behavior with different users around me. Sometime the interface shows that an action has been recorded (as with the selection of the student file) but the program doesn't react accordingly. The solution I use is to quit AMC. When AMC is launched again, the information is updated and the problem is gone.

RE: Strange behavior in development version - Added by S. McKay over 5 years ago

Ok, thanks. It's good to know its not just me. I'll try to put together a bug report next week (this week is crazy).

RE: Strange behavior in development version - Added by Alexis Bienvenüe over 5 years ago

This may be related with #468. I tried to address some of these problems with commit hg:53c1fffca527, but I'm afraid not all of them.
If you can, please post a step by step procedure to reproduce it, that could be very helpfull to fix it.

RE: Strange behavior in development version - Added by S. McKay over 5 years ago

Sorry, Alexis,

I did not see your reply until now. Hopefully you will see mine ....

I am running AMC 1.3.0+hg2016-11-09. If you have a project where you have printed the exams, the students have taken them and you have run the scans back into AMC, the problem occurs when you click the mark button. Marks are calculated, but the mean shown on the gui does not update. I have been able to fix it by shutting down amc, restarting, and then reselecting the project. The correct mean is then shown. I don't know if this is a cosmetic problem, or if there are bigger problems underneath, and this is just a symptom. Restarting AMC corrects it however.

The problem also occurs when first selecting the primary key - the dropdown box has no options. Once you restart, however, you can select it.

This happens consistently with every project I run. It's not critical, but is annoying.