Error when marking (all zeroes)

Added by Dario Compagno over 7 years ago

Hi everyone,
this is my first post here: I am a new AMC user, and I just used it for my first exam.

I managed to produce the questions and scan the results. Everything seems to work fine: the correct cases are recognized.

But when I ask to grade the papers, all marks are zeroes!
I tried to do back and forth from the txt file, selecting the option "Update marking scale" but with no luck.

Could anyone help me with this please?
I am attaching the txt source file.

I am running Auto-Multiple-Choice on Linux Mint 17.1

simple-txt.txt - Source file (17.3 kB)


Replies (10)

RE: Error when marking (all zeroes) - Added by Alexis Bienvenüe over 7 years ago

Can you switch to debugging mode (from Help menu) before computing the marks (with "Update marking scale" ticked), and then post the log file?

RE: Error when marking (all zeroes) - Added by Dario Compagno over 7 years ago

Thanks for your help,

I am attaching the file. The issue may be in the lines "nonpositive value for MAX"...

(Please not that I chose 25 as maximum mark in the "Project" option)

Dario

RE: Error when marking (all zeroes) - Added by shreikant kv over 7 years ago

See the example from documentation:
*{b=2,m=-1} What is the capital city of France?
+ Paris
- Lille
- Marseille
- Ouagadougou
-{-2} New York

In your questions scoring strategy like {b=2,m=-1} is missing?

RE: Error when marking (all zeroes) - Added by Alexis Bienvenüe over 7 years ago

In your questions scoring strategy like {b=2,m=-1} is missing?

There is a default scoring strategy: the {...} part is not mandatory.

RE: Error when marking (all zeroes) - Added by Alexis Bienvenüe over 7 years ago

Your log files look strange. Can you send an archive of the whole project directory?

RE: Error when marking (all zeroes) - Added by Dario Compagno over 7 years ago

Hi Alexis,

actually I produced the project with a machine (with Ubuntu 14.04 on it) and then I tried to grade it with another machine (with Linux Mint on it) because the first was broken.

Today I accessed the project from the first machine that created it and I managed to grade all correctly. Thank you anyway for your help.

However, it would be cool if projects where portable from one machine to another!

Do you still want to give a look at the project directory?

Best
Dario

RE: Error when marking (all zeroes) - Added by Alexis Bienvenüe over 7 years ago

However, it would be cool if projects where portable from one machine to another!

It should be the case.
Did you try a full AMC cycle on the Linux Mint machine, to see if the is some installation problem with it?

RE: Error when marking (all zeroes) - Added by S K over 6 years ago

I didn't try "the full cycle", just installed what comes with synaptic. My machine is also Mint. On Ubuntu, the hand-corrected misrecognitions were saved and one could proceed with them, but on Mint one cannot hand-curate the scans. Technically you can, but when it comes to the grading part, AMC just goes with the initial recognition, ignoring all the changes.
Short: on Ubuntu it worked fine, on Mint somehow it doesn't always.

RE: Error when marking (all zeroes) - Added by S K over 6 years ago

Ignore my previous message. Everything works on Mint, it was just that I misinterpreted AMC's corrections. Sorry for the confusion.

RE: Error when marking (all zeroes) - Added by Alexis Bienvenüe over 6 years ago

Good! Thanks for the report.

(1-10/10)