Installing AMC on Arch Linux

Added by Ben French almost 4 years ago

I am attempting to install AMC on arch linux. The package builds are no longer available, thus I am compiling from source.
I have installed the prerequsites but I am recieving this error.

fatal error: ppm.h: No such file or directory

I have installed libnetpbm

I assume I need to change the make.conf file to point at Arch linux's netpbm directory?
How can I do this?

thanks in advance


Replies (55)

RE: Installing AMC on Arch Linux - Added by c b 8 months ago

Hello Alexis and thanks for the quick reply :)

The result of the command is :

AMC/DataModule/layout.pm => /usr/lib/perl5/5.28/site_perl/AMC/DataModule/layout.pm
AMC/Basic.pm => /usr/lib/perl5/5.28/site_perl/AMC/Basic.pm
AMC/DataModule.pm => /usr/lib/perl5/5.28/site_perl/AMC/DataModule.pm

You say:

If you have multiple perl installations, pick up the same as the one at the first line of AMC-gui.pl.

- How do I see if I have multiple perl installations ?
- What do you mean by "pick up the same as [...]" (I mean: how do I "pick up")
- The first line of AMC-gui.pl is

#! /usr/bin/perl -w

So what do I have to do ?

RE: Installing AMC on Arch Linux - Added by Alexis Bienvenüe 8 months ago

- How do I see if I have multiple perl installations ?

If you don't know, it should not be the case

AMC/DataModule/layout.pm => /usr/lib/perl5/5.28/site_perl/AMC/DataModule/layout.pm

It seems to me from the PKGBUILD at https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/auto-multiple-choice that AMC packages are installed in the directory /usr/share/perl5/vendor_perl.
Can you check that you can find them in /usr/share/perl5/vendor_perl/AMC?
Then, can you try to uninstall those in /usr/lib/perl5/5.28/site_perl? Maybe backup and remove the directory /usr/lib/perl5/5.28/site_perl/AMC/ with its contents.

RE: Installing AMC on Arch Linux - Added by Alexis Bienvenüe 8 months ago

The package builds are no longer available

I thought they are: https://www.archlinux.org/packages/community/x86_64/auto-multiple-choice/
Is there any problem with this?

RE: Installing AMC on Arch Linux - Added by c b 8 months ago

It worked !!!!
I just removed what you said and reinstalled the perl dependencies listed in https://www.archlinux.org/packages/community/x86_64/auto-multiple-choice/

TY very much Alexis :)

RE: Installing AMC on Arch Linux - Added by thibault dupont 7 months ago

Hi!

Another missing dependancy on archlinux : extra/netpbm

Thx for the package!

« Previous 1 2 3 (51-55/55)