Installing AMC on Arch Linux

Added by Ben French over 3 years ago

I am attempting to install AMC on arch linux. The package builds are no longer available, thus I am compiling from source.
I have installed the prerequsites but I am recieving this error.

fatal error: ppm.h: No such file or directory

I have installed libnetpbm

I assume I need to change the make.conf file to point at Arch linux's netpbm directory?
How can I do this?

thanks in advance


Replies (54)

RE: Installing AMC on Arch Linux - Added by Alexis Bienvenüe 3 months ago

This package was created by Thomas Legrand : see RE: Installing AMC on Arch Linux and https://aur.archlinux.org/packages/auto-multiple-choice/.
I'm afraid I don't know how ArchLinux packaging works…

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu 3 months ago

Hello,

I've managed to install amc on archlinux with the help of Alexis, see this topic in french...

https://project.auto-multiple-choice.net/boards/4/topics/7362?r=7365#message-7365

I am now in holidays but when I go home I will try installing amc from scratch and maybe update the aur repository because I've totally forgotten to do it last time !

Benoit

RE: Installing AMC on Arch Linux - Added by Giovanni Giuffrida 3 months ago

Thanks Benoit, I'll be waiting. I've been trying to install it from the scratch meanwhile but still could not succeed. I'll keep on trying :)

Thanks again

Giovanni

RE: Installing AMC on Arch Linux - Added by Thomas LEGRAND 3 months ago

Hey guys

Sorry but my archlinux pc is broke. So I can't update the repository.

I think I can pull the AUR repository and update directly the current repository.

I know in the archlinux wiki you can find a good page to understand how to create or update a current AUR project.

RE: Installing AMC on Arch Linux - Added by Thomas LEGRAND 3 months ago

Thomas LEGRAND wrote:

Hey guys

Sorry but my archlinux pc is broken . So I can't update the repository.

I think I can pull the AUR repository and update directly the current repository.

I know in the archlinux wiki you can find a good page to understand how to create or update a current AUR project.

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu 2 months ago

Hello,

If you can wait 2-3 days, I will work on that and I will update the aur repository (I've never do that but I'm sure archwiki will help me as always !)

Greetings,

Benoit

RE: Installing AMC on Arch Linux - Added by Aser Ty 2 months ago

Hi,
any news about the AUR package update ?
Is It possible to just paste the PKGBUILD file somewhere (pastebin, gitlab, github, or something else).
I really need to install it.
Thanks

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu 2 months ago

Hi,
package in aur are up-to-date !
Benoit

RE: Installing AMC on Arch Linux - Added by Giovanni Giuffrida 2 months ago

Thanks Benoit... I was able to install it finally!

I'm getting now a Latex error, when I compile my exam in Italian latex format, I need to figure out, but it seems something related to the Italian vowels.

Thanks again

Giovanni

RE: Installing AMC on Arch Linux - Added by Aser Ty 2 months ago

Benoit, thank you very much for this update.
Cheers

RE: Installing AMC on Arch Linux - Added by Aser Ty 2 months ago

It works but perl-gtk3 should be added as a dependency otherwise it won't start.
Thanks again

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu 2 months ago

I add perl-gtk3 as dependency.

Benoit

RE: Installing AMC on Arch Linux - Added by pierre sallard 2 months ago

When reinstalling AMC with yaourt, I got this error message : "missing target : gtk3-perl" (see the opposite order of "gtk3" and "perl" when compared to the package name that is mentioned just above).

Any advice to solve this issue ?

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu 2 months ago

pierre sallard wrote:

When reinstalling AMC with yaourt, I got this error message : "missing target : gtk3-perl" (see the opposite order of "gtk3" and "perl" when compared to the package name that is mentioned just above).

Any advice to solve this issue ?

Hello,

Pierre this problem is now solved. I didn't check the name of the package (gtk2-perl and perl-gtk3 !), first time I maintained a package on aur.

Benoit

RE: Installing AMC on Arch Linux - Added by c b about 1 month ago

Hello,
AMC (1.4.0 rc 1 installed via yaourt) doesn't work anymore since the updgrade of opencv in version 4.0.
Someone experimenting the same problem ?

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu about 1 month ago

c b wrote:

Hello,
AMC (1.4.0 rc 1 installed via yaourt) doesn't work anymore since the updgrade of opencv in version 4.0.
Someone experimenting the same problem ?

I will look at this issue and post here if I found a solution.

Benoit

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu about 1 month ago

thanks to Alexis for the help !

amc is now working again in aur ;)

Benoit

RE: Installing AMC on Arch Linux - Added by c b about 1 month ago

Good news but when I try to compile a new bareme.tex, pdflatex complains that ic can't find the file "automultiplechoice.sty" which disappeared since this update :(

Am I missing something ?

RE: Installing AMC on Arch Linux - Added by c b about 1 month ago

Ok, I went further (workaround by manually copying the file found in an archive in my latex tree).

Now, just after pdflatex compiled my bareme.tex I got the message "Can't locate object method "clear_mep" via package "AMC::DataModule::layout" at /usr/lib/AMC/perl/AMC-meptex.pl line 194.
"

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu about 1 month ago

ok I have to fix this story of sty...

for the perl error, I will search the error because I have not tested to compile a file with amc...

RE: Installing AMC on Arch Linux - Added by thibault dupont 13 days ago

Hi,

Just to let you know that the package "extra/perl-clone" is not in the dependancy and cause a no compilation during the "update document".

RE: Installing AMC on Arch Linux - Added by Benoit Landrieu 11 days ago

thibault dupont wrote:

Hi,

Just to let you know that the package "extra/perl-clone" is not in the dependancy and cause a no compilation during the "update document".

corrected ;)

RE: Installing AMC on Arch Linux - Added by c b 9 days ago

First I would like to thank you for all this work (and the good news to see an AMC package in community)

So I reinstalled AMC using this package 1.4 from community.
I still get this error :
"Can't locate object method "clear_mep" via package "AMC::DataModule::layout" at /usr/lib/AMC/perl/AMC-meptex.pl line 194."
when I calculate the layouts (after updating the documents without problem).

Maybe it's a problem linked to perl (since I had to try lots of manual CPAN installations with perl modules).

Thanks again for your help :)

RE: Installing AMC on Arch Linux - Added by Alexis Bienvenüe 9 days ago

Can you try the following command to see which file is actually loaded as AMC::DataModule::layout?

perl -MAMC::DataModule::layout -e'print $_ . " => " . $INC{$_} . "\n" for grep { /^AMC/ } keys %INC'

If you have multiple perl installations, pick up the same as the one at the first line of AMC-gui.pl.

« Previous 1 2 3 Next » (26-50/54)