Probleme de police "Linux Libertine" sur MACOSX catalina (Feature #783)


Added by Pascal Boulet 7 months ago. Updated 7 months ago.


Status:New Start date:10/17/2021
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-

Description

Bonjour,

J'ai installé la dernière version de AMC avec homebrew sur mon MAC version catalina.
Lors de l'exécution, j'ai une erreur liée à la police de caractères "Linux Libertine" qui n'est pas trouvée alors que je l'ai installée à partir du site:
https://guido.vonrudorff.de/2014/linux-libertine-on-macos/

J'ai essayé les "patch" proposés sur le forum ici:
https://project.auto-multiple-choice.net/boards/4/topics/5137
et ici:
https://project.auto-multiple-choice.net/issues/293

J'ai installé les fichiers de police de caractères dans /Library/Fonts, comme indiqué sur ce site:
https://perso.univ-lyon2.fr/~brogniar/notes/amc-installation/

Mais rien ne marche.

Une idée de comment s'en sortir?

Merci
Pascal


History

Updated by Joël Brogniart 7 months ago

Pourriez vous indiquer le résultat de la commande suivante dans Terminal ?

ls -al /Library/Fonts

Updated by Pascal Boulet 7 months ago

Voici:

rw-r--r- 1 pascal admin 36 28 avr 08:59 .uuid
lrwxr-xr-x 1 root admin 52 10 jul 2020 Arial Unicode.ttf@ > /System/Library/Fonts/Supplemental/Arial Unicode.ttf
-rw-r--r-
1 pascal staff 122992 2 jul 2012 LinBiolinum_K.otf
-rw-r--r--
1 pascal staff 418076 2 jul 2012 LinBiolinum_R.otf
rw-r--r- 1 pascal staff 514532 2 jul 2012 LinBiolinum_RB.otf
-rw-r--r--
1 pascal staff 662776 2 jul 2012 LinBiolinum_RI.otf
rw-r--r- 1 pascal staff 383672 2 jul 2012 LinLibertine_DR.otf
-rw-r--r--
1 pascal staff 399004 2 jul 2012 LinLibertine_I.otf
rw-r--r- 1 pascal staff 139864 2 jul 2012 LinLibertine_M.otf
-rw-r--r--
1 pascal staff 528064 2 jul 2012 LinLibertine_R.otf
rw-r--r- 1 pascal staff 426060 2 jul 2012 LinLibertine_RB.otf
-rw-r--r--
1 pascal staff 363740 2 jul 2012 LinLibertine_RBI.otf
rw-r--r- 1 pascal staff 445044 2 jul 2012 LinLibertine_RI.otf
-rw-r--r--
1 pascal staff 350264 2 jul 2012 LinLibertine_RZ.otf
rw-r--r-@ 1 pascal staff 397388 2 jul 2012 LinLibertine_RZI.otf
rw-r--r- 1 root admin 4070 17 oct 16:32 encodings.dir
rw-r--r- 1 root admin 3501 17 oct 16:32 fonts.dir
rw-r--r- 1 root admin 56 17 oct 16:32 fonts.list
rw-r--r- 1 root admin 3501 17 oct 16:32 fonts.scale

Updated by Joël Brogniart 7 months ago

Ça a l'air correct. Si c'est bien le contenu de /Library/Fonts X11 devrait les trouver sans problème. Je ne vois pas pourquoi ça échoue. Mais je ne suis pas du tout un spécialiste de Homebrew.

Updated by Pascal Boulet 7 months ago

Bonjour,

Bon, j'ai essayé avec macPort. J'ai d'abord désinstallé AMC avec homebrew. Mais là, le résultat est pire: l'interface d'AMC ne se lance pas. J'ai le message d'erreur suivant:
Can't locate Gtk3.pm in @INC (you may need to install the Gtk3 module) (@INC contains: /opt/local/lib/perl5/site_perl/5.28/darwin-thread-multi-2level /opt/local/lib/perl5/site_perl/5.28 /opt/local/lib/perl5/vendor_perl/5.28/darwin-thread-multi-2level /opt/local/lib/perl5/vendor_perl/5.28 /opt/local/lib/perl5/5.28/darwin-thread-multi-2level /opt/local/lib/perl5/5.28) at /opt/local/lib/AMC/perl/AMC-gui.pl line 26.
BEGIN failed--compilation aborted at /opt/local/lib/AMC/perl/AMC-gui.pl line 26.

Le problème a déjà été relevé (cf. post https://project.auto-multiple-choice.net/issues/769)

J'ai tapé les commandes données dans ce post, mais je n'ai pas les résultats attendus:
locate Path.pm|grep -i amc ne renvoie rien

ls /opt/local/lib/perl5/ renvoie ceci: 5.28/ 5.30/ site_perl/ vendor_perl/

perl -v donne entre autre: This is perl 5, version 28, subversion 3 (v5.28.3)

Là je ne vois pas quoi faire. Avez-vous une idée?

Merci
Cordialement,

Updated by Joël Brogniart 7 months ago

Si vous avez suivi exactement les instructions de https://project.auto-multiple-choice.net/issues/769#note-1 ou Installation_d'AMC_sous_macOS_avec_MacPorts le soucis est certainement lié à l'installation conjointe de MacPorts et Homebrew.

Avez vous bien installé la version 5.30 de Perl5 en tant que version par défaut avant de poursuivre la suite des différentes étapes de l'installation ?
C'était l'instruction suivante.

sudo port install perl5 +perl5_30

Also available in: Atom PDF