Problème installation de la version test (Support #775)


Added by Jean Bertin 8 months ago. Updated 8 months ago.


Status:New Start date:09/10/2021
Priority:Urgent Due date:
Assignee:- % Done:

0%

Category:-
Target version:-

Description

Bonjour,
Afin d'essayer la version test, je tape dans le terminal:

sudo add-apt-repository ppa:alexis.bienvenue/test

J'obtiens alors le message suivant:

Cannot add PPA: 'ppa:~alexis.bienvenue/ubuntu/test'.
ERROR: '~alexis.bienvenue' user or team does not exist.

Je ne comprends pas d'où vient le problème.
Merci de votre réponse.


Probl__me_QCM-A5.png (73.8 kB) Jean Bertin, 09/11/2021 04:47 pm

Preremplies.tex (1.7 kB) Jean Bertin, 09/11/2021 04:47 pm

AMC-DEBUG-Lci8EK4K.log (34.7 kB) Jean Bertin, 09/11/2021 11:14 pm


History

Updated by Frédéric Bréal 8 months ago

Une idée tradive : essayez-vous d'installer AMC via le réseau d'un établissement scolaire ? Le pare-feu peut bloquer l'accès.

Updated by Jean Bertin 8 months ago

Merci. Effectivement il s'agit du réseau d'un établissement.
Je verrai ce problème la semaine prochaine.

Par contre, j'ai enfin réussi à installer la version 1.5.0 chez moi, et malheureusement le problème de décalage en A5 est toujours présent.
AMC ne m'indique aucune erreur, le calcul de mise en page se fait et la barre devient verte, par contre les cases rouges ne sont pas du tout superposées avec les cases à cocher comme c'est le cas en A4 et le "code barre" du dessus n'est pas pris en compte...
Je ne sais pas comment faire....

Updated by Frédéric Bréal 8 months ago

Je n'ai pas de problème de positionnement.
Pouvez-vous relancer la compilation en mode débogage (aide > débogage) puis déposer le fichier log, sous ubuntu il se trouve dans tmp ?

Updated by Jean Bertin 8 months ago

Voici le fichier en question.

Updated by Frédéric Bréal 8 months ago

Je viens de reproduire le bogue mais je ne sais pas comment.
Impossible de revenir en arrière. J'ai beau recommencer avec le fichier, j'ai le même décalage.

Updated by Frédéric Bréal 8 months ago

J'ai trouvé et ce n'est pas bon signe.
Le moteur latex+dvipdf me semble responsable de ce problème.
C'est étrange car j'ai quasiment utlisé ce moteur de compilation depuis que j'utilise AMC, je dessine avec pstricks.
Modifiez le moteur par défaut ou juste pour ce projet en pdflatex ou xelatex.
Allez dans préférences puis Général ou Projet.

J'ai testé avec un autre sujet modèle et le décalage apparaît.
Je vais ouvrir un fil sur ce bogue.

Updated by Jean Bertin 8 months ago

Bonsoir,
en effet le mode latex + dvipdfm ne fonctionne pas pour le format A5, or je dessine aussi avec psTicks et c'est ce système de compilation qui convient.

Updated by Frédéric Bréal 8 months ago

Plusieurs pistes pour contourner le problème :
- imprimer en 2 sur 1 avec une feuille A4.
- utiliser le paquet \usepackage[pspdf={-dNOSAFER}]{auto-pst-pdf} et compiler avec pdflatex ou dALLOWPSTRANSPARENCY si gs > 9.52
faire les figures avec la classe standalone et les appeler avec \includegraphic et compiler en pdflatex

Updated by Frédéric Bréal 8 months ago

Plusieurs pistes pour contourner le problème :
  • imprimer en 2 sur 1 avec une feuille A4.
  • utiliser le paquet \usepackage[pspdf={-dNOSAFER}]{auto-pst-pdf} et compiler avec pdflatex ou -dALLOWPSTRANSPARENCY si gs > 9.52
  • faire les figures avec la classe standalone et les appeler avec \includegraphic et compiler en pdflatex

Updated by Jean Bertin 8 months ago

Bonjour,
AMC peut fonctionner si le sujet est fait en A4 et le scan en A5 (2 A4 réduits sur une seule feuille) ?

Updated by Frédéric Bréal 8 months ago

Sans souci. Il faudra penser, peut-être, à modifier les paramètres de détection dans l'onglet scan (majoration et minortion). J'ai mis respectiviement 0.20 et 0.30.

Le sujet initial : https://drive.infomaniak.com/app/share/136176/164b8b71-d431-4360-bd27-f70473da3474
le sujet mis en page avec pdftk pour une immpression en 2/1 https://drive.infomaniak.com/app/share/136176/2d4af5a5-875a-4546-b3c3-26631e3aff54

Also available in: Atom PDF