Problème de sujet en format A5 (Bug #772)


Added by Jean Bertin 11 months ago. Updated 9 months ago.


Status:Feedback Start date:07/01/2021
Priority:Normal Due date:
Assignee:Alexis Bienvenüe % Done:

0%

Category:LaTeX
Target version:-

Description

Bonjour,
Tout d'abord, j'utilise AMC depuis quelques temps et j'en suis pleinement satisfait: MERCI pour ce fabuleux logiciel !

Je rencontre par contre un problème lorsque je veux faire des sujets en A5.
Le calcul de mise en page se fait normalement (l'icône passe au vert) mais lors de la vérification de mise en page les cases rouges ne sont pas superposées aux cases à cocher du sujet.
Je ne comprends pas d'où vient le problème...

J'utilise la version 1.4.0 avec Ubuntu et cela fonctionne parfaitement en A4.


Preremplies.tex (1.7 kB) Jean Bertin, 07/01/2021 03:49 pm

probleme-a5.png (67 kB) Jean Bertin, 07/01/2021 03:49 pm


History

Updated by Frédéric Bréal 11 months ago

Essayez en ajoutant

\usepackage{geometry}

ou
\usepackage[a5paper]{geometry}

Updated by Jean Bertin 11 months ago

Bonjour,
merci pour cette réponse. Dans l'emballement, j'avais envoyé le fichier le plus simple possible et j'avais oublié d'ajouter le package geometry (mais il est dans mes documents de travail normaux).
Je l'ai ajouté au fichier envoyé et le problème reste malheureusement identique...

Si geometry est placé avant automultiplechoice, le problème subsiste.
S'il je le place après, lors du calcul de mise en page, j'ai:
Latex error: options clash for package geometry

Updated by Frédéric Bréal 11 months ago

Je n'ai pas de souci de compilation ou de décalage avec le fichier testé que j'enlève la ligne 53 ou que je rajoute le paquet geometry avant ou après autmultiplechoice.
J'ai la version test et xubuntu 20.04.

Updated by Jean Bertin 11 months ago

Bonjour,
je n'arrive pas à installer la version test.
Je suis sous ubuntu 20.04.
J'ai téléchargé auto-multiple-choice_1.5.0~rc2_precomp.tar.gz
mais étant novice en ubuntu, je n'arrive pas à m'en sortir...

Voilà ce que je tape (et ce que j'obtiens) dans le terminal:

/home/tice/Téléchargements/auto-multiple-choice-1.5.0~rc2 make ; sudo make install
bash: /home/tice/Téléchargements/auto-multiple-choice-1.5.0~rc2 : est un dossier
make: *** Aucune règle pour fabriquer la cible « install ». Arrêt.

Updated by Frédéric Bréal 11 months ago

Utilisez l'installation par ppa.

sudo add-apt-repository ppa:alexis.bienvenue/test && sudo apt-get update sudo apt-get install auto-multiple-choice && sudo apt-get install msmtp

msmtp c'est pour l'envoi des copies par mail.

Updated by Alexis Bienvenüe 11 months ago

  • Status changed from New to Feedback

Updated by Jean Bertin 9 months ago

Bonjour, avec la rentrée les affaires reprennent...
Lorsque je tape ce qui est proposé en #5 dans le terminal, j'obtiens un message d'erreur

tice@UBUNTU-SALLE-05:~$ sudo add-apt-repository ppa:alexis.bienvenue/test && sudo apt-get update sudo apt-get install auto-multiple-choice && sudo apt-get install msmtp
[sudo] Mot de passe de tice :

Cannot add PPA: 'ppa:~alexis.bienvenue/ubuntu/test'.
ERROR: '~alexis.bienvenue' user or team does not exist.

Merci de votre réponse.

Updated by Frédéric Bréal 9 months ago

sudo add-apt-repository ppa:alexis.bienvenue/test && sudo apt-get update && sudo apt-get install auto-multiple-choice && sudo apt-get install msmtp

J'ai oublié le && entre update et sudo.

Updated by Jean Bertin 9 months ago

Bonjour, j'obtiens ceci:

Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Ign :2 http://ppa.launchpad.net/alexis.bienvenue/amc/ubuntu focal InRelease
Réception de :3 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Atteint :4 http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal InRelease
Réception de :5 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Err :6 http://ppa.launchpad.net/alexis.bienvenue/amc/ubuntu focal Release
404 Not Found [IP : 91.189.95.85 80]

Ensuite, Reception de 7 à 31 semble se faire normalement, puis:

E: Le dépôt http://ppa.launchpad.net/alexis.bienvenue/amc/ubuntu focal Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

Updated by Frédéric Bréal 9 months ago

Je ne saurais vous aider. J'ai réussi à l'installer avec xubuntu 20.04.
Essayez sans && sudo apt-get install msmtp.
Sinon remplacez test par stable.

Also available in: Atom PDF