ERROR(): No layout for ID +0/0/0+

Added by Thierry TSANG 2 months ago

Bonjour,

Lorsque j'effectue la saisie automatique de la copie se nommant "test-0001.pdf" et se trouvant à l'intérieur du dossier "scans" du projet à l'aide de l'interface graphique AMC, j'obtiens la sortie commande suivante :

Page : +1/2/59+
Page : +1/1/60+
===<analyse>=+0.5
===<analyse>=+0.5
===<analyse>=+1

Cependant quand j'exécute la commande ci-contre à l'intérieur du dossier du projet : auto-multiple-choice analyse --projet ./ ./scans/test-0001.pdf
J'obtiens l'erreur ci-dessous :

Page : +0/0/0+
Page : +0/0/0+
Page : +0/0/0+
Page : +0/0/0+
ERROR(): No layout for ID +0/0/0+

Comment faire pour régler ce problème s'il vous plaît ?
Merci d'avance pour votre aide.
LegendaryThierry

Main.zip - Projet Main (863.1 kB)


Replies (8)

RE: ERROR(): No layout for ID +0/0/0+ - Added by Thierry TSANG 2 months ago

Je vous rajoute également en pièce jointe de ce message, le fichier log contenant les informations de debug de la commande.

LegendaryThierry

RE: ERROR(): No layout for ID +0/0/0+ - Added by Alexis Bienvenüe 2 months ago

Vous n'avez vraisemblablement pas utilisé les mêmes options lors de votre appel à auto-multiple-choice analse.
Effectuez une saisie automatique en mode débogage à partir d'AMC : vous pourrez voir les arguments utilisés par AMC lors de son appel.

RE: ERROR(): No layout for ID +0/0/0+ - Added by Cédric F. 19 days ago

Bonjour à tous,

Je reprends cette erreur car j'ai exactement la même.

Page : 0/0/0
Page : 0/0/0
Page : 0/0/0
Page : 0/0/0
ERROR: No layout for ID 0/0/0
===<analyse>=+1

C'est un QCM de 3 pages, pour 16 élèves. Seule différence avec mes précédents, c'est scanné en niveaux de gris. J'ai aussi eu un soucis car j'ai déplacé mon dossier QCM sur un partage réseau (NFS) qui contenait un accent. J'ai renommé le é en e et la compilation s'est bien passée par la suite (je ne sais pas si c'est un bug connu).

Effectuez une saisie automatique en mode débogage à partir d'AMC : vous pourrez voir les arguments utilisés par AMC lors de son appel.

Comment faire cela ?

Merci !

RE: ERROR(): No layout for ID +0/0/0+ - Added by Cédric F. 19 days ago

J'ai oublié de préciser, cela a peut-être une importance : je suis sous Ubuntu Xenial 16.04.

RE: ERROR(): No layout for ID +0/0/0+ - Added by Cédric F. 19 days ago

Du coup, j'ai avancé et testé avec mon portable sous Ubuntu 18.04. J'ai récupéré la version AMC 1.4.0 alors que sur mon Xenial, je suis en version 1.3.0.

Et cela a fonctionné parfaitement \o/

Du coup, je ne sais pas trop pourquoi cela ne fonctionne plus alors que j'ai utilisé cet AMC il y a quelques semaines... Dépendances cassées ?

Est-il possible d'installer AMC 1.4.0 sur Xenial ? (j'ai déjà le ppa:alexis.bienvenue/amc

Merci !

RE: ERROR(): No layout for ID +0/0/0+ - Added by Cédric F. 16 days ago

Je suis à jour sur mon Xenial et visiblement c'est normal que je n'ai que la version 1.3.0 : https://launchpad.net/~alexis.bienvenue/+archive/ubuntu/amc?field.series_filter=xenial

RE: ERROR(): No layout for ID +0/0/0+ - Added by Gérard Carpeaux 16 days ago

Je n'avais pas vu le deuxième filtre.
Il faut installer le dépôt test qui est en fait la version stable aussi.
Il n'y a pas eu de mise à jour depuis.

(1-8/8)