Problème correction UTF-8

Added by Patrick Aymar 5 months ago

Désolé mais j'ai encore un souci au niveau d'une correction suite à la mise à jour de AMC.
J'ai des erreurs sur chaque copie à la console et la correction ne se fait pas.
Voici la fin du log :

\T1/ppl/b/n/9 Question 17 |  \T1/ppl/m/n/9 Lorsque la fl?che du lien d'as-so-ci
a-tion pointe vers l'?l?-ment de flux, il s'agit :
Underfull \hbox (badness 10000) in paragraph at lines 732--732
[3] [4] [5] [6]
Underfull \hbox (badness 10000) in paragraph at lines 732--732
[7] [8] [9] [10]
Underfull \hbox (badness 10000) in paragraph at lines 732--732
[11] [12]
Underfull \hbox (badness 10000) in paragraph at lines 732--732
[13] [14] [15] (./amc-compiled.aux) )
(see the transcript file for additional information){/usr/local/texlive/2018/te
xmf-dist/fonts/enc/dvips/base/8r.enc}{/usr/local/texlive/2018/texmf-dist/fonts/
enc/dvips/lm/lm-ec.enc}</usr/local/texlive/2018/texmf-dist/fonts/type1/public/a
msfonts/cm/cmr17.pfb></usr/local/texlive/2018/texmf-dist/fonts/type1/public/ams
fonts/cm/cmsy10.pfb></usr/local/texlive/2018/texmf-dist/fonts/type1/public/amsf
onts/latxfont/lcircle1.pfb></usr/local/texlive/2018/texmf-dist/fonts/type1/publ
ic/lm/lmtt10.pfb></usr/local/texlive/2018/texmf-dist/fonts/type1/public/amsfont
s/symbols/msam10.pfb></usr/local/texlive/2018/texmf-dist/fonts/type1/urw/palati
no/uplb8a.pfb></usr/local/texlive/2018/texmf-dist/fonts/type1/urw/palatino/uplr
8a.pfb>
Output written on amc-compiled.pdf (1875 pages, 6580876 bytes).
Transcript written on amc-compiled.log.

J'ai en principe corrigé le jeu de caractère, mon fichier qcmS32015.tex et TexShop sont en UTF-8 et la composition fonctionne.

Voila la question incriminée :

\element{CONCEPT}{
\begin{question}{q25}
Lorsque la flèche du lien d'association pointe vers l'élément de flux, il s'agit :
\includegraphics[scale=0.6]{obj-consul.png}
\begin{reponses}
\bonne{d'une consultation}
\mauvaise{d'une création}
\mauvaise{d'une modification}
\mauvaise{d'une suppression}
\end{reponses}
\end{question}
}

Curieusement la sortie console de la correction montre un mauvaise encodage des caractères latin : fl?che.
J'avoue être un peu perdu.


Replies (2)

RE: Problème correction UTF-8 - Added by Gérard Carpeaux 5 months ago

J'aurai tendance à écrire

é en \'e

et
è en \`e

pour vérifier si cela corrige le problème avant de chercher une autre solution que je n'ai pas.

RE: Problème correction UTF-8 - Added by Patrick Aymar 4 months ago

C'est résolu.
J'avais un vieux automultiplechoice.sty dans le répertoire du projet.
L'erreur signalé par AMC était une incompatibilité entre LaTeX et AMC.

(1-2/2)