Problème avec le fichier csv d'identification des étudiants

Added by Joss OUIN about 1 year ago

Bonjour à tous,

Pour l'identification des étudiants, j'ai fait des essais avec un fichier "test" en csv (en utf8) et là tout allait bien.
Aujourd'hui, j'essaie avec le fichier csv "réel" des étudiants et AMC ne "reconnaît" que les prénoms et pas les noms. Du coup il me dit que j'ai des doublons (mêmes prénoms bien sûr). Dans le tableur LibreOffice, je n'ai que 2 colonnes, les numéros et les prénoms (donc pas les noms).
Je joins mon fichier csv.

Please, help.

Cordialement.
Joss.


Replies (5)

RE: Problème avec le fichier csv d'identification des étudiants - Added by Alexis Bienvenüe about 1 year ago

Le premier caractère de votre fichier est U+FEFF, et il semble que cela perturbe AMC, car l'en-tête de la première colonne n'est plus "nom" mais "<U+FEFF>nom".
Vous avez deux solutions :
  1. retirer ce caractère (voir fichier ci-joint)
  2. rajouter une première colonne inutile à votre fichier csv : par exemple, une colonne "rien" avec uniquement des valeurs vides. Comme ça le <U+FEFF> viendra polluer "rien" et non "nom".

RE: Problème avec le fichier csv d'identification des étudiants - Added by Joss OUIN about 1 year ago

Mille mercis !!!
Je me demande bien d'où il est apparu ce <U+FEEF> car j'avais bien noté sur la documentation AMC qu'il fallait sauvegarder en utf-8.
Je pense que cela vient de LibreOffice : j'ai créé le "csv" à partir de la feuille LibreOffice. Il faut que je regarde du côté des réglages de LibreOffice.

Merci encore une fois !
Bonne continuation.
Joss.

RE: Problème avec le fichier csv d'identification des étudiants - Added by Alexis Bienvenüe about 1 year ago

Oui il faut regarder quel est le logiciel qui a ajouté ce caractère spécial…
On voit bien si ce caractère est là ou pas en utilisant less fichier.csv dans un terminal.

RE: Problème avec le fichier csv d'identification des étudiants - Added by Joss OUIN about 1 year ago

Merci pour l'info sur le Terminal, je ne connaissais pas.
En fait j'ai créé le "csv" à partir de LibreOffice en faisant "enregistrer sous..." puis je me suis aperçu qu'il n'était pas en utf-8. Je l'ai donc ouvert avec un éditeur de base (éditeur d'Ubuntu) et j'ai coché l'option "utf-8" en l'enregistrant à nouveau.
Il faut que je trouve comment "tout faire" à partir de LibreOffice afin de ne pas faire apparaître de terme <U+FEEF> (si jamais cela vient de là).

Ceci dit :
Ma première correction avec AMC (même si je n'ai pas encore les "Noms" mais cela va s'arranger) :
27 copies corrigées en quelques secondes ! Que du Bonheur !

Joss.

RE: Problème avec le fichier csv d'identification des étudiants - Added by Joss OUIN about 1 year ago

Je reviens sur ce post pour donner ce qui me semble être la solution.
En fait il ne faut pas ouvrir le fichier avec l'éditeur d'Ubuntu pour sélectionner le codage "utf-8".
Ce qu'il faut faire :
1/ Compléter votre feuille LibreOffice ;
2/ Faire "Enregistrer sous..." et choisir le format "csv" en cochant la case : "Editer les paramètres du filtre" ;
3/ Une boîte s'ouvre alors et là il faut sélectionner le codage "utf-8" ;
4/ Valider par OK.

Ensuite dans le Terminal, lorsque je tape "less monfichier.csv" le <U+FEEF> a disparu !!
C'est tout simplement merveilleux.

Belle journée à tous.
Joss.

(1-5/5)