changer la version de AMC

Added by amira khalifa over 3 years ago

j'ai la version 1.3.0 de AMC et je veux migrer vers 1.1.0 pour que je puisse utiliser les commandes de AMC proposé par http://project.auto-multiple-choice.net/projects/auto-multiple-choice/wiki/Using_AMC_in_command_line_only

comment je peux changer la version svp?
Merci


Replies (4)

RE: changer la version de AMC - Added by amira khalifa over 3 years ago

update :
quand j'ai essayé d'exécuter j'avais quelques erreurs du coup j'ai pensé que peut être à cause de la version de AMC . tout fonctionnait bien jusqu'à la commande auto-multiple-choice analyse --projet ./ ./scans/* qui m'affiche :

Page : +0/0/0+
Page : +0/0/0+
Page : +0/0/0+
Page : +0/0/0+
ERROR(): No layout for ID +0/0/0+

RE: changer la version de AMC - Added by Alexis Bienvenüe over 3 years ago

Pouvez-vous rajouter l'option de débogage --debug /tmp/debug.log, et poster le fichier /tmp/debug.log produit ?

RE: changer la version de AMC - Added by amira khalifa over 3 years ago

Je vous remercie pour votre réponse, je joint le fichier debug généré. Quand j'utilise le fichier avec GUI de l'AMC ça fonctionne très bien, mais pas avec la ligne de commande. J'ai besoin d'exécuter ce script dans une application symfony donc je ne peux travailler qu'avec la ligne de commande.

RE: changer la version de AMC - Added by Alexis Bienvenüe over 3 years ago

Vous pouvez effectuer vos traitements depuis l'interface graphique en mode débogage (depuis le menu Aide) : vous trouverez les commandes utilisées dans le fichier log.
Il faut passer à analyse un fichier bitmap, et non un fichier PDF. Pour extraire les fichiers bitmap des scans en PDF, utilisez auto-multiple-choice getimages.

(1-4/4)