Versions d'AMC avec Ubuntu 18.04 et 20.04 ?

Added by Joss OUIN 12 days ago

Bonjour à tous,

Actuellement j'ai la version 18.04 d'Ubuntu et la version AMC "test" : 1.4.0+git2020-08-24

Je voudrais savoir si je dois installer la mise à jour d'Ubuntu et donc passer à la version 20.04 pour pouvoir continuer à utiliser AMC dans ses futures versions.
(Je précise que je ne suis pas un expert d'Ubuntu (et j'espère que l'upgrade 18.04 -> 20.04 fonctionnera bien sans m'obliger à tout réinstaller)).

Si je peux rester en Ubuntu 18.04, cela ne me dérangerait pas du tout.

Merci d'avance pour les infos que vous pourrez m'apporter à ce sujet.

Bien cordialement.
J/O


Replies (22)

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 11 days ago

Bonjour à tous,

J'ai effectué la mise à jour d'Ubuntu 18.04 vers 20.04.
Suite à cette mise à jour, AMC ne se lance plus. Je suis donc allé dans le gestionnaire de paquets "Synaptic" et j'ai coché le paquet "AMC" (qui avait été décoché lors de l'installation de la nouvelle version d'Ubuntu).
J'ai ensuite essayé de réinstaller AMC mais j'ai cette erreur suivante (boîte de dialogue Synaptic) :

auto-multiple-choice:
 Dépend : libopencv-core4.2 mais ne doit pas être installé
 Dépend : libopencv-imgcodecs4.2 mais ne doit pas être installé
 Dépend : libopencv-imgproc4.2 mais ne doit pas être installé
  Dépend : auto-multiple-choice-common (=1.4.0+git2020-08-23-1~focal1) mais 1.4.0+git2020-08-24-1~bionic2 doit être installé
  Recommande : auto-multiple-choice-doc (=1.4.0+git2020-08-23-1~focal1) mais 1.4.0+git2020-08-24-1~bionic2 doit être installé

Est-ce que quelqu'un aurait une idée ?

Bonne journée.
Joss.

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Alexis Bienvenüe 10 days ago

Que renvoie la commande suivante dans un terminal ?

sudo apt-get install auto-multiple-choice

Peut-être que le dépôt test est resté attaché à l'ancienne version d'ubuntu ? Pouvez-vous voir ce que renvoie la commande

grep -r alexis /etc/apt/sources.list*

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

Bonjour,

Merci de me venir en aide !
La première commande dans un Terminal renvoie :

ouin-j@ouinj-Ubuntu:~$ sudo apt-get install auto-multiple-choice
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 auto-multiple-choice : Dépend: auto-multiple-choice-common (= 1.4.0+git2020-08-23-1~focal1) mais 1.4.0+git2020-08-24-1~bionic2 devra être installé
                        Recommande: auto-multiple-choice-doc (= 1.4.0+git2020-08-23-1~focal1) mais 1.4.0+git2020-08-24-1~bionic2 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

La deuxième renvoie :

ouin-j@ouinj-Ubuntu:~$ grep -r alexis /etc/apt/sources.list*
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-test-bionic.list.save:deb http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal main # désactivé pour la mise à niveau vers focal
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-test-bionic.list.save:# deb-src http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu bionic main
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-test-bionic.list:deb http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal main # désactivé pour la mise à niveau vers focal
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-test-bionic.list:# deb-src http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu bionic main
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-amc-bionic.list.distUpgrade:deb http://ppa.launchpad.net/alexis.bienvenue/amc/ubuntu bionic main
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-amc-stable-focal.list:deb http://ppa.launchpad.net/alexis.bienvenue/amc-stable/ubuntu focal main
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-amc-stable-focal.list:# deb-src http://ppa.launchpad.net/alexis.bienvenue/amc-stable/ubuntu focal main
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-amc-bionic.list.save:# deb http://ppa.launchpad.net/alexis.bienvenue/amc/ubuntu focal main # désactivé pour la mise à niveau vers focal
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-amc-bionic.list:# deb http://ppa.launchpad.net/alexis.bienvenue/amc/ubuntu focal main # désactivé pour la mise à niveau vers focal
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-test-bionic.list.distUpgrade:deb http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu bionic main
/etc/apt/sources.list.d/alexis_bienvenue-ubuntu-test-bionic.list.distUpgrade:# deb-src http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu bionic main

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Alexis Bienvenüe 10 days ago

Je crois qu'on peut faire le ménage sur les PPA :

sudo rm /etc/apt/sources.list.d/alexis_bienvenue-ubuntu*
sudo add-apt-repository ppa:alexis.bienvenue/test
sudo apt-get update

Puis
sudo apt-get install auto-multiple-choice=1.4.0+git2020-08-23-1~focal1

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

J'ai saisi les commandes :

ouin-j@ouinj-Ubuntu:~$ sudo rm /etc/apt/sources.list.d/alexis_bienvenue-ubuntu*

ouin-j@ouinj-Ubuntu:~$ sudo add-apt-repository ppa:alexis.bienvenue/test

 Plus d’info : https://launchpad.net/~alexis.bienvenue/+archive/ubuntu/test
Appuyez sur [ENTRÉE] pour continuer ou sur Ctrl-c pour annuler l'ajout.

Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal InRelease                         
Atteint :3 http://archive.canonical.com/ubuntu focal InRelease                                           
Atteint :4 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                                                                                    
Atteint :5 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal InRelease                                                                          
Atteint :6 http://security.ubuntu.com/ubuntu focal-security InRelease                                                        
Atteint :7 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease
Atteint :8 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease
Lecture des listes de paquets... Fait
ouin-j@ouinj-Ubuntu:~$ sudo apt-get update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                                                          
Atteint :3 http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal InRelease                                                
Atteint :4 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                              
Atteint :5 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease                                                                                                                 
Atteint :6 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal InRelease                                                                                                         
Atteint :7 http://security.ubuntu.com/ubuntu focal-security InRelease                                                          
Atteint :8 http://archive.canonical.com/ubuntu focal InRelease                               
Lecture des listes de paquets... Fait

ouin-j@ouinj-Ubuntu:~$ sudo apt-get install auto-multiple-choice=1.4.0+git2020-08-23-1~focal1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 auto-multiple-choice : Dépend: auto-multiple-choice-common (= 1.4.0+git2020-08-23-1~focal1) mais 1.4.0+git2020-08-24-1~bionic2 devra être installé
                        Recommande: auto-multiple-choice-doc (= 1.4.0+git2020-08-23-1~focal1) mais 1.4.0+git2020-08-24-1~bionic2 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Il y a encore des paquets "garder en l'état".

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Alexis Bienvenüe 10 days ago

La version est "plus ancienne" sur focal que sur bionic, ce qui doit gêner.
Peut-être en désinstallant puis réinstallant ?

sudo apt-get remove auto-multiple-choice
sudo apt-get autoremove
sudo apt-get install auto-multiple-choice

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

J'ai saisi ces commandes mais AMC ne se lande toujours pas.
Le clique sur l'icône dans la liste des logiciels. Comment faire pour le lancer depuis le Terminal (pour faire un test) ?

ouin-j@ouinj-Ubuntu:~$ sudo apt-get remove auto-multiple-choice
[sudo] Mot de passe de ouin-j : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet « auto-multiple-choice » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  auto-multiple-choice-common auto-multiple-choice-doc libaprutil1-dbd-mysql libconvert-binhex-perl libcrystalhd3 libdbd-sqlite3-perl libdbi-perl libemail-messageid-perl libgeronimo-validation-1.0-spec-java
  libgfortran4 libgraphics-magick-perl libgraphicsmagick-q16-3 liblaf-plugin-java libllvm9 liblua5.3-0 libpq5 libtagsoup-java linux-hwe-5.4-headers-5.4.0-51 nextcloud-client-l10n
  python-backports.functools-lru-cache python-dateutil python-decorator python-gobject-2 python-numpy python-ply python-pyparsing python-six python-subprocess32 python-typing python-tz unetbootin-translations
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 8 non mis à jour.
ouin-j@ouinj-Ubuntu:~$ sudo apt-get autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  auto-multiple-choice-common auto-multiple-choice-doc libaprutil1-dbd-mysql libconvert-binhex-perl libcrystalhd3 libdbd-sqlite3-perl libdbi-perl libemail-messageid-perl libgeronimo-validation-1.0-spec-java
  libgfortran4 libgraphics-magick-perl libgraphicsmagick-q16-3 liblaf-plugin-java libllvm9 liblua5.3-0 libpq5 libtagsoup-java linux-hwe-5.4-headers-5.4.0-51 nextcloud-client-l10n
  python-backports.functools-lru-cache python-dateutil python-decorator python-gobject-2 python-numpy python-ply python-pyparsing python-six python-subprocess32 python-typing python-tz unetbootin-translations
0 mis à jour, 0 nouvellement installés, 31 à enlever et 7 non mis à jour.
Après cette opération, 172 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 663125 fichiers et répertoires déjà installés.)
Suppression de auto-multiple-choice-common (1.4.0+git2020-08-24-1~bionic2) ...
Suppression de auto-multiple-choice-doc (1.4.0+git2020-08-24-1~bionic2) ...
Suppression de libaprutil1-dbd-mysql:amd64 (1.6.1-4ubuntu2) ...
Suppression de libconvert-binhex-perl (1.125-1) ...
Suppression de libcrystalhd3:amd64 (1:0.0~git20110715.fdd2f19-13build1) ...
Suppression de libdbd-sqlite3-perl:amd64 (1.64-1build1) ...
Suppression de libdbi-perl:amd64 (1.643-1) ...
Suppression de libemail-messageid-perl (1.406-1) ...
Suppression de libgeronimo-validation-1.0-spec-java (1.1-3) ...
Suppression de libgfortran4:amd64 (7.5.0-6ubuntu2) ...
Suppression de libgraphics-magick-perl (1.4+really1.3.35-1) ...
Suppression de libgraphicsmagick-q16-3 (1.4+really1.3.35-1) ...
Suppression de liblaf-plugin-java (7.3+dfsg3-5) ...
Suppression de libllvm9:amd64 (1:9.0.1-12) ...
Suppression de liblua5.3-0:amd64 (5.3.3-1.1ubuntu2) ...
Suppression de libpq5:amd64 (12.4-0ubuntu0.20.04.1) ...
Suppression de libtagsoup-java (1.2.1+-1) ...
Suppression de linux-hwe-5.4-headers-5.4.0-51 (5.4.0-51.56~18.04.1) ...
Suppression de nextcloud-client-l10n (2.6.5-20200713.144448.adada8b2e-1.0~bionic1) ...
Suppression de python-backports.functools-lru-cache (1.5-3build1) ...
E: namespace:121: cannot remove /usr/lib/python2.7/dist-packages/backports/__init__.py
Suppression de python-dateutil (2.7.3-3ubuntu1) ...
Suppression de python-decorator (4.4.2-0ubuntu1) ...
Suppression de python-gobject-2 (2.28.6-14ubuntu1) ...
Suppression de python-numpy (1:1.16.5-2ubuntu7) ...
Suppression de python-ply (3.11-3build1) ...
Suppression de python-pyparsing (2.4.6-1) ...
Suppression de python-six (1.14.0-2) ...
Suppression de python-subprocess32 (3.5.4-2) ...
Suppression de python-typing (3.6.6-2) ...
Suppression de python-tz (2019.3-1) ...
Suppression de unetbootin-translations (681-1~bionic1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour doc-base (0.10.9) ...
Traitement de 1 fichier de documentation supprimé…
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Traitement des actions différées (« triggers ») pour tex-common (6.13) ...
Running mktexlsr. This may take some time... done.
Running mtxrun --generate. This may take some time... done.
Traitement des actions différées (« triggers ») pour shared-mime-info (1.15-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) ...
ouin-j@ouinj-Ubuntu:~$ sudo apt-get install auto-multiple-choice
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  auto-multiple-choice-common auto-multiple-choice-doc gdal-data libaec0 libarmadillo9 libarpack2 libcfitsio8 libcharls2 libclass-load-perl libclass-load-xs-perl libclass-tiny-perl libconvert-binhex-perl
  libdap25 libdapclient6v5 libdbd-sqlite3-perl libdbi-perl libdevel-overloadinfo-perl libdevel-partialdump-perl libemail-abstract-perl libemail-address-xs-perl libemail-messageid-perl
  libemail-mime-contenttype-perl libemail-mime-encodings-perl libemail-mime-perl libemail-sender-perl libemail-simple-perl libepsilon1 libfilesys-df-perl libfreexl1 libfyba0 libgdal26 libgdcm3.0 libgeos-3.8.0
  libgeos-c1v5 libgeotiff5 libgraphics-magick-perl libgraphicsmagick-q16-3 libhdf4-0-alt libhdf5-103 libkmlbase1 libkmldom1 libkmlengine1 libmime-tools-perl libmodule-pluggable-perl
  libmodule-runtime-conflicts-perl libmoose-perl libmoox-types-mooselike-perl libnet-cups-perl libnetcdf15 libodbc1 libogdi4.1 libopencv-core4.2 libopencv-imgcodecs4.2 libopencv-imgproc4.2
  libopenoffice-oodoc-perl libpackage-deprecationmanager-perl libpq5 libproj15 libqhull7 libsocket++1 libspatialite7 libsuperlu5 libsys-cpu-perl libsz2 libtbb2 libtext-wrapper-perl libthrowable-perl
  liburiparser1 libxerces-c3.2 odbcinst odbcinst1debian2 proj-bin proj-data
Paquets suggérés :
  libmldbm-perl libnet-daemon-perl libsql-statement-perl geotiff-bin gdal-bin libgeotiff-epsg graphicsmagick-dbg libhdf4-doc libhdf4-alt-dev hdf4-tools libmoox-types-mooselike-numeric-perl
  libmoox-types-setobject-perl libmyodbc odbc-postgresql tdsodbc unixodbc-bin ogdi-bin
Les NOUVEAUX paquets suivants seront installés :
  auto-multiple-choice auto-multiple-choice-common auto-multiple-choice-doc gdal-data libaec0 libarmadillo9 libarpack2 libcfitsio8 libcharls2 libclass-load-perl libclass-load-xs-perl libclass-tiny-perl
  libconvert-binhex-perl libdap25 libdapclient6v5 libdbd-sqlite3-perl libdbi-perl libdevel-overloadinfo-perl libdevel-partialdump-perl libemail-abstract-perl libemail-address-xs-perl libemail-messageid-perl
  libemail-mime-contenttype-perl libemail-mime-encodings-perl libemail-mime-perl libemail-sender-perl libemail-simple-perl libepsilon1 libfilesys-df-perl libfreexl1 libfyba0 libgdal26 libgdcm3.0 libgeos-3.8.0
  libgeos-c1v5 libgeotiff5 libgraphics-magick-perl libgraphicsmagick-q16-3 libhdf4-0-alt libhdf5-103 libkmlbase1 libkmldom1 libkmlengine1 libmime-tools-perl libmodule-pluggable-perl
  libmodule-runtime-conflicts-perl libmoose-perl libmoox-types-mooselike-perl libnet-cups-perl libnetcdf15 libodbc1 libogdi4.1 libopencv-core4.2 libopencv-imgcodecs4.2 libopencv-imgproc4.2
  libopenoffice-oodoc-perl libpackage-deprecationmanager-perl libpq5 libproj15 libqhull7 libsocket++1 libspatialite7 libsuperlu5 libsys-cpu-perl libsz2 libtbb2 libtext-wrapper-perl libthrowable-perl
  liburiparser1 libxerces-c3.2 odbcinst odbcinst1debian2 proj-bin proj-data
0 mis à jour, 74 nouvellement installés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de prendre 31,5 Mo dans les archives.
Après cette opération, 118 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de :1 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libtbb2 amd64 2020.1-2 [124 kB]
Réception de :2 http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal/main amd64 auto-multiple-choice-common all 1.4.0+git2020-08-23-1~focal1 [504 kB]
Réception de :3 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libopencv-core4.2 amd64 4.2.0+dfsg-5 [1 027 kB]
Réception de :4 http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal/main amd64 auto-multiple-choice amd64 1.4.0+git2020-08-23-1~focal1 [31,8 kB]
Réception de :5 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libopencv-imgproc4.2 amd64 4.2.0+dfsg-5 [1 290 kB]
Réception de :6 http://ppa.launchpad.net/alexis.bienvenue/test/ubuntu focal/main amd64 auto-multiple-choice-doc all 1.4.0+git2020-08-23-1~focal1 [168 kB]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 gdal-data all 3.0.4+dfsg-1build3 [186 kB]
Réception de :8 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libarpack2 amd64 3.7.0-3 [92,8 kB]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libsuperlu5 amd64 5.2.1+dfsg1-4 [159 kB]
Réception de :10 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libarmadillo9 amd64 1:9.800.4+dfsg-1build1 [93,2 kB]
Réception de :11 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libcfitsio8 amd64 3.470-3 [466 kB]
Réception de :12 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libcharls2 amd64 2.0.0+dfsg-1build1 [74,1 kB]
Réception de :13 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libdap25 amd64 3.20.5-1 [435 kB]
Réception de :14 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libdapclient6v5 amd64 3.20.5-1 [92,2 kB]
Réception de :15 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libepsilon1 amd64 0.9.2+dfsg-4 [41,0 kB]
Réception de :16 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libfreexl1 amd64 1.0.5-3 [33,4 kB]
Réception de :17 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libfyba0 amd64 4.1.1-6build1 [113 kB]
Réception de :18 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libgeos-3.8.0 amd64 3.8.0-1build1 [535 kB]
Réception de :19 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libgeos-c1v5 amd64 3.8.0-1build1 [69,9 kB]
Réception de :20 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 proj-data all 6.3.1-1 [7 647 kB]
Réception de :21 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libproj15 amd64 6.3.1-1 [925 kB]                                                                                                        
Réception de :22 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libgeotiff5 amd64 1.5.1-2 [53,1 kB]                                                                                                     
Réception de :23 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libhdf4-0-alt amd64 4.2.14-1ubuntu1 [268 kB]                                                                                            
Réception de :24 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libaec0 amd64 1.0.4-1 [19,1 kB]                                                                                                         
Réception de :25 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libsz2 amd64 1.0.4-1 [5 188 B]                                                                                                          
Réception de :26 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libhdf5-103 amd64 1.10.4+repack-11ubuntu1 [1 311 kB]                                                                                    
Réception de :27 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 liburiparser1 amd64 0.9.3-2 [39,3 kB]                                                                                                   
Réception de :28 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libkmlbase1 amd64 1.3.0-8build1 [45,4 kB]                                                                                               
Réception de :29 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libkmldom1 amd64 1.3.0-8build1 [152 kB]                                                                                                 
Réception de :30 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libkmlengine1 amd64 1.3.0-8build1 [72,5 kB]                                                                                             
Réception de :31 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libnetcdf15 amd64 1:4.7.3-1 [341 kB]                                                                                                    
Réception de :32 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 libodbc1 amd64 2.3.6-0.1build1 [189 kB]                                                                                                     
Réception de :33 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libogdi4.1 amd64 4.1.0+ds-1build1 [198 kB]                                                                                              
Réception de :34 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libpq5 amd64 12.4-0ubuntu0.20.04.1 [113 kB]                                                                                         
Réception de :35 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libqhull7 amd64 2015.2-4 [152 kB]                                                                                                       
Réception de :36 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libspatialite7 amd64 4.3.0a-6build1 [1 286 kB]                                                                                          
Réception de :37 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libxerces-c3.2 amd64 3.2.2+debian-1build3 [878 kB]                                                                                      
Réception de :38 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 odbcinst amd64 2.3.6-0.1build1 [14,8 kB]                                                                                                    
Réception de :39 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 odbcinst1debian2 amd64 2.3.6-0.1build1 [41,1 kB]                                                                                            
Réception de :40 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libgdal26 amd64 3.0.4+dfsg-1build3 [6 156 kB]                                                                                           
Réception de :41 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libsocket++1 amd64 1.12.13-10build1 [40,7 kB]                                                                                           
Réception de :42 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libgdcm3.0 amd64 3.0.5-1.1ubuntu2 [1 871 kB]                                                                                            
Réception de :43 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libopencv-imgcodecs4.2 amd64 4.2.0+dfsg-5 [112 kB]                                                                                      
Réception de :44 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libgraphicsmagick-q16-3 amd64 1.4+really1.3.35-1 [1 136 kB]                                                                             
Réception de :45 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libgraphics-magick-perl amd64 1.4+really1.3.35-1 [53,9 kB]                                                                              
Réception de :46 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 libdbi-perl amd64 1.643-1 [730 kB]                                                                                                          
Réception de :47 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libdbd-sqlite3-perl amd64 1.64-1build1 [154 kB]                                                                                         
Réception de :48 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libclass-load-perl all 0.25-1 [13,5 kB]                                                                                                 
Réception de :49 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libclass-load-xs-perl amd64 0.10-1build4 [13,8 kB]                                                                                      
Réception de :50 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libclass-tiny-perl all 1.006-1 [16,8 kB]                                                                                                
Réception de :51 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 libconvert-binhex-perl all 1.125-1 [29,7 kB]                                                                                                
Réception de :52 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libdevel-overloadinfo-perl all 0.005-1 [6 780 B]                                                                                        
Réception de :53 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libdevel-partialdump-perl all 0.20-1 [14,2 kB]                                                                                          
Réception de :54 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-simple-perl all 2.216-1 [18,9 kB]                                                                                              
Réception de :55 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libmodule-pluggable-perl all 5.2-1 [21,9 kB]                                                                                            
Réception de :56 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-abstract-perl all 3.008-2 [19,7 kB]                                                                                            
Réception de :57 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-address-xs-perl amd64 1.04-1build2 [27,2 kB]                                                                                   
Réception de :58 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-messageid-perl all 1.406-1 [7 990 B]                                                                                           
Réception de :59 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-mime-contenttype-perl all 1.022-1 [9 500 B]                                                                                    
Réception de :60 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-mime-encodings-perl all 1.315-2 [6 772 B]                                                                                      
Réception de :61 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-mime-perl all 1.946-1 [34,8 kB]                                                                                                
Réception de :62 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libmoox-types-mooselike-perl all 0.29-1 [17,5 kB]                                                                                       
Réception de :63 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libthrowable-perl all 0.200013-1 [14,8 kB]                                                                                              
Réception de :64 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libemail-sender-perl all 1.300034-1 [66,6 kB]                                                                                           
Réception de :65 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 libfilesys-df-perl amd64 0.92-6build4 [12,4 kB]                                                                                             
Réception de :66 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 libmime-tools-perl all 5.509-1 [192 kB]                                                                                                     
Réception de :67 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libmodule-runtime-conflicts-perl all 0.003-1 [6 598 B]                                                                                  
Réception de :68 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libpackage-deprecationmanager-perl all 0.17-1 [15,3 kB]                                                                                 
Réception de :69 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libmoose-perl amd64 2.2012-2 [747 kB]                                                                                                   
Réception de :70 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libnet-cups-perl amd64 0.64-1build2 [49,3 kB]                                                                                           
Réception de :71 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libopenoffice-oodoc-perl all 2.125-3 [443 kB]                                                                                           
Réception de :72 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libsys-cpu-perl amd64 0.61-2build4 [9 172 B]                                                                                            
Réception de :73 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 libtext-wrapper-perl all 1.05-2 [10,3 kB]                                                                                               
Réception de :74 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 proj-bin amd64 6.3.1-1 [88,8 kB]                                                                                                        
31,5 Mo réceptionnés en 17s (1 860 ko/s)                                                                                                                                                                          
Extraction des modèles depuis les paquets : 100%
Sélection du paquet libtbb2:amd64 précédemment désélectionné.
(Lecture de la base de données... 644130 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libtbb2_2020.1-2_amd64.deb ...
Dépaquetage de libtbb2:amd64 (2020.1-2) ...
Sélection du paquet libopencv-core4.2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../01-libopencv-core4.2_4.2.0+dfsg-5_amd64.deb ...
Dépaquetage de libopencv-core4.2:amd64 (4.2.0+dfsg-5) ...
Sélection du paquet libopencv-imgproc4.2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../02-libopencv-imgproc4.2_4.2.0+dfsg-5_amd64.deb ...
Dépaquetage de libopencv-imgproc4.2:amd64 (4.2.0+dfsg-5) ...
Sélection du paquet gdal-data précédemment désélectionné.
Préparation du dépaquetage de .../03-gdal-data_3.0.4+dfsg-1build3_all.deb ...
Dépaquetage de gdal-data (3.0.4+dfsg-1build3) ...
Sélection du paquet libarpack2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../04-libarpack2_3.7.0-3_amd64.deb ...
Dépaquetage de libarpack2:amd64 (3.7.0-3) ...
Sélection du paquet libsuperlu5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../05-libsuperlu5_5.2.1+dfsg1-4_amd64.deb ...
Dépaquetage de libsuperlu5:amd64 (5.2.1+dfsg1-4) ...
Sélection du paquet libarmadillo9 précédemment désélectionné.
Préparation du dépaquetage de .../06-libarmadillo9_1%3a9.800.4+dfsg-1build1_amd64.deb ...
Dépaquetage de libarmadillo9 (1:9.800.4+dfsg-1build1) ...
Sélection du paquet libcfitsio8:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../07-libcfitsio8_3.470-3_amd64.deb ...
Dépaquetage de libcfitsio8:amd64 (3.470-3) ...
Sélection du paquet libcharls2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../08-libcharls2_2.0.0+dfsg-1build1_amd64.deb ...
Dépaquetage de libcharls2:amd64 (2.0.0+dfsg-1build1) ...
Sélection du paquet libdap25:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../09-libdap25_3.20.5-1_amd64.deb ...
Dépaquetage de libdap25:amd64 (3.20.5-1) ...
Sélection du paquet libdapclient6v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../10-libdapclient6v5_3.20.5-1_amd64.deb ...
Dépaquetage de libdapclient6v5:amd64 (3.20.5-1) ...
Sélection du paquet libepsilon1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../11-libepsilon1_0.9.2+dfsg-4_amd64.deb ...
Dépaquetage de libepsilon1:amd64 (0.9.2+dfsg-4) ...
Sélection du paquet libfreexl1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../12-libfreexl1_1.0.5-3_amd64.deb ...
Dépaquetage de libfreexl1:amd64 (1.0.5-3) ...
Sélection du paquet libfyba0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../13-libfyba0_4.1.1-6build1_amd64.deb ...
Dépaquetage de libfyba0:amd64 (4.1.1-6build1) ...
Sélection du paquet libgeos-3.8.0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../14-libgeos-3.8.0_3.8.0-1build1_amd64.deb ...
Dépaquetage de libgeos-3.8.0:amd64 (3.8.0-1build1) ...
Sélection du paquet libgeos-c1v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../15-libgeos-c1v5_3.8.0-1build1_amd64.deb ...
Dépaquetage de libgeos-c1v5:amd64 (3.8.0-1build1) ...
Sélection du paquet proj-data précédemment désélectionné.
Préparation du dépaquetage de .../16-proj-data_6.3.1-1_all.deb ...
Dépaquetage de proj-data (6.3.1-1) ...
Sélection du paquet libproj15:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../17-libproj15_6.3.1-1_amd64.deb ...
Dépaquetage de libproj15:amd64 (6.3.1-1) ...
Sélection du paquet libgeotiff5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../18-libgeotiff5_1.5.1-2_amd64.deb ...
Dépaquetage de libgeotiff5:amd64 (1.5.1-2) ...
Sélection du paquet libhdf4-0-alt précédemment désélectionné.
Préparation du dépaquetage de .../19-libhdf4-0-alt_4.2.14-1ubuntu1_amd64.deb ...
Dépaquetage de libhdf4-0-alt (4.2.14-1ubuntu1) ...
Sélection du paquet libaec0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../20-libaec0_1.0.4-1_amd64.deb ...
Dépaquetage de libaec0:amd64 (1.0.4-1) ...
Sélection du paquet libsz2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../21-libsz2_1.0.4-1_amd64.deb ...
Dépaquetage de libsz2:amd64 (1.0.4-1) ...
Sélection du paquet libhdf5-103:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../22-libhdf5-103_1.10.4+repack-11ubuntu1_amd64.deb ...
Dépaquetage de libhdf5-103:amd64 (1.10.4+repack-11ubuntu1) ...
Sélection du paquet liburiparser1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../23-liburiparser1_0.9.3-2_amd64.deb ...
Dépaquetage de liburiparser1:amd64 (0.9.3-2) ...
Sélection du paquet libkmlbase1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../24-libkmlbase1_1.3.0-8build1_amd64.deb ...
Dépaquetage de libkmlbase1:amd64 (1.3.0-8build1) ...
Sélection du paquet libkmldom1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../25-libkmldom1_1.3.0-8build1_amd64.deb ...
Dépaquetage de libkmldom1:amd64 (1.3.0-8build1) ...
Sélection du paquet libkmlengine1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../26-libkmlengine1_1.3.0-8build1_amd64.deb ...
Dépaquetage de libkmlengine1:amd64 (1.3.0-8build1) ...
Sélection du paquet libnetcdf15:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../27-libnetcdf15_1%3a4.7.3-1_amd64.deb ...
Dépaquetage de libnetcdf15:amd64 (1:4.7.3-1) ...
Sélection du paquet libodbc1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../28-libodbc1_2.3.6-0.1build1_amd64.deb ...
Dépaquetage de libodbc1:amd64 (2.3.6-0.1build1) ...
Sélection du paquet libogdi4.1 précédemment désélectionné.
Préparation du dépaquetage de .../29-libogdi4.1_4.1.0+ds-1build1_amd64.deb ...
Dépaquetage de libogdi4.1 (4.1.0+ds-1build1) ...
Sélection du paquet libpq5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../30-libpq5_12.4-0ubuntu0.20.04.1_amd64.deb ...
Dépaquetage de libpq5:amd64 (12.4-0ubuntu0.20.04.1) ...
Sélection du paquet libqhull7:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../31-libqhull7_2015.2-4_amd64.deb ...
Dépaquetage de libqhull7:amd64 (2015.2-4) ...
Sélection du paquet libspatialite7:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../32-libspatialite7_4.3.0a-6build1_amd64.deb ...
Dépaquetage de libspatialite7:amd64 (4.3.0a-6build1) ...
Sélection du paquet libxerces-c3.2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../33-libxerces-c3.2_3.2.2+debian-1build3_amd64.deb ...
Dépaquetage de libxerces-c3.2:amd64 (3.2.2+debian-1build3) ...
Sélection du paquet odbcinst précédemment désélectionné.
Préparation du dépaquetage de .../34-odbcinst_2.3.6-0.1build1_amd64.deb ...
Dépaquetage de odbcinst (2.3.6-0.1build1) ...
Sélection du paquet odbcinst1debian2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../35-odbcinst1debian2_2.3.6-0.1build1_amd64.deb ...
Dépaquetage de odbcinst1debian2:amd64 (2.3.6-0.1build1) ...
Sélection du paquet libgdal26 précédemment désélectionné.
Préparation du dépaquetage de .../36-libgdal26_3.0.4+dfsg-1build3_amd64.deb ...
Dépaquetage de libgdal26 (3.0.4+dfsg-1build3) ...
Sélection du paquet libsocket++1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../37-libsocket++1_1.12.13-10build1_amd64.deb ...
Dépaquetage de libsocket++1:amd64 (1.12.13-10build1) ...
Sélection du paquet libgdcm3.0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../38-libgdcm3.0_3.0.5-1.1ubuntu2_amd64.deb ...
Dépaquetage de libgdcm3.0:amd64 (3.0.5-1.1ubuntu2) ...
Sélection du paquet libopencv-imgcodecs4.2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../39-libopencv-imgcodecs4.2_4.2.0+dfsg-5_amd64.deb ...
Dépaquetage de libopencv-imgcodecs4.2:amd64 (4.2.0+dfsg-5) ...
Sélection du paquet libgraphicsmagick-q16-3 précédemment désélectionné.
Préparation du dépaquetage de .../40-libgraphicsmagick-q16-3_1.4+really1.3.35-1_amd64.deb ...
Dépaquetage de libgraphicsmagick-q16-3 (1.4+really1.3.35-1) ...
Sélection du paquet libgraphics-magick-perl précédemment désélectionné.
Préparation du dépaquetage de .../41-libgraphics-magick-perl_1.4+really1.3.35-1_amd64.deb ...
Dépaquetage de libgraphics-magick-perl (1.4+really1.3.35-1) ...
Sélection du paquet libdbi-perl:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../42-libdbi-perl_1.643-1_amd64.deb ...
Dépaquetage de libdbi-perl:amd64 (1.643-1) ...
Sélection du paquet libdbd-sqlite3-perl:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../43-libdbd-sqlite3-perl_1.64-1build1_amd64.deb ...
Dépaquetage de libdbd-sqlite3-perl:amd64 (1.64-1build1) ...
Sélection du paquet auto-multiple-choice-common précédemment désélectionné.
Préparation du dépaquetage de .../44-auto-multiple-choice-common_1.4.0+git2020-08-23-1~focal1_all.deb ...
Dépaquetage de auto-multiple-choice-common (1.4.0+git2020-08-23-1~focal1) ...
Sélection du paquet auto-multiple-choice précédemment désélectionné.
Préparation du dépaquetage de .../45-auto-multiple-choice_1.4.0+git2020-08-23-1~focal1_amd64.deb ...
Dépaquetage de auto-multiple-choice (1.4.0+git2020-08-23-1~focal1) ...
Sélection du paquet auto-multiple-choice-doc précédemment désélectionné.
Préparation du dépaquetage de .../46-auto-multiple-choice-doc_1.4.0+git2020-08-23-1~focal1_all.deb ...
Dépaquetage de auto-multiple-choice-doc (1.4.0+git2020-08-23-1~focal1) ...
Sélection du paquet libclass-load-perl précédemment désélectionné.
Préparation du dépaquetage de .../47-libclass-load-perl_0.25-1_all.deb ...
Dépaquetage de libclass-load-perl (0.25-1) ...
Sélection du paquet libclass-load-xs-perl précédemment désélectionné.
Préparation du dépaquetage de .../48-libclass-load-xs-perl_0.10-1build4_amd64.deb ...
Dépaquetage de libclass-load-xs-perl (0.10-1build4) ...
Sélection du paquet libclass-tiny-perl précédemment désélectionné.
Préparation du dépaquetage de .../49-libclass-tiny-perl_1.006-1_all.deb ...
Dépaquetage de libclass-tiny-perl (1.006-1) ...
Sélection du paquet libconvert-binhex-perl précédemment désélectionné.
Préparation du dépaquetage de .../50-libconvert-binhex-perl_1.125-1_all.deb ...
Dépaquetage de libconvert-binhex-perl (1.125-1) ...
Sélection du paquet libdevel-overloadinfo-perl précédemment désélectionné.
Préparation du dépaquetage de .../51-libdevel-overloadinfo-perl_0.005-1_all.deb ...
Dépaquetage de libdevel-overloadinfo-perl (0.005-1) ...
Sélection du paquet libdevel-partialdump-perl précédemment désélectionné.
Préparation du dépaquetage de .../52-libdevel-partialdump-perl_0.20-1_all.deb ...
Dépaquetage de libdevel-partialdump-perl (0.20-1) ...
Sélection du paquet libemail-simple-perl précédemment désélectionné.
Préparation du dépaquetage de .../53-libemail-simple-perl_2.216-1_all.deb ...
Dépaquetage de libemail-simple-perl (2.216-1) ...
Sélection du paquet libmodule-pluggable-perl précédemment désélectionné.
Préparation du dépaquetage de .../54-libmodule-pluggable-perl_5.2-1_all.deb ...
Dépaquetage de libmodule-pluggable-perl (5.2-1) ...
Sélection du paquet libemail-abstract-perl précédemment désélectionné.
Préparation du dépaquetage de .../55-libemail-abstract-perl_3.008-2_all.deb ...
Dépaquetage de libemail-abstract-perl (3.008-2) ...
Sélection du paquet libemail-address-xs-perl précédemment désélectionné.
Préparation du dépaquetage de .../56-libemail-address-xs-perl_1.04-1build2_amd64.deb ...
Dépaquetage de libemail-address-xs-perl (1.04-1build2) ...
Sélection du paquet libemail-messageid-perl précédemment désélectionné.
Préparation du dépaquetage de .../57-libemail-messageid-perl_1.406-1_all.deb ...
Dépaquetage de libemail-messageid-perl (1.406-1) ...
Sélection du paquet libemail-mime-contenttype-perl précédemment désélectionné.
Préparation du dépaquetage de .../58-libemail-mime-contenttype-perl_1.022-1_all.deb ...
Dépaquetage de libemail-mime-contenttype-perl (1.022-1) ...
Sélection du paquet libemail-mime-encodings-perl précédemment désélectionné.
Préparation du dépaquetage de .../59-libemail-mime-encodings-perl_1.315-2_all.deb ...
Dépaquetage de libemail-mime-encodings-perl (1.315-2) ...
Sélection du paquet libemail-mime-perl précédemment désélectionné.
Préparation du dépaquetage de .../60-libemail-mime-perl_1.946-1_all.deb ...
Dépaquetage de libemail-mime-perl (1.946-1) ...
Sélection du paquet libmoox-types-mooselike-perl précédemment désélectionné.
Préparation du dépaquetage de .../61-libmoox-types-mooselike-perl_0.29-1_all.deb ...
Dépaquetage de libmoox-types-mooselike-perl (0.29-1) ...
Sélection du paquet libthrowable-perl précédemment désélectionné.
Préparation du dépaquetage de .../62-libthrowable-perl_0.200013-1_all.deb ...
Dépaquetage de libthrowable-perl (0.200013-1) ...
Sélection du paquet libemail-sender-perl précédemment désélectionné.
Préparation du dépaquetage de .../63-libemail-sender-perl_1.300034-1_all.deb ...
Dépaquetage de libemail-sender-perl (1.300034-1) ...
Sélection du paquet libfilesys-df-perl précédemment désélectionné.
Préparation du dépaquetage de .../64-libfilesys-df-perl_0.92-6build4_amd64.deb ...
Dépaquetage de libfilesys-df-perl (0.92-6build4) ...
Sélection du paquet libmime-tools-perl précédemment désélectionné.
Préparation du dépaquetage de .../65-libmime-tools-perl_5.509-1_all.deb ...
Dépaquetage de libmime-tools-perl (5.509-1) ...
Sélection du paquet libmodule-runtime-conflicts-perl précédemment désélectionné.
Préparation du dépaquetage de .../66-libmodule-runtime-conflicts-perl_0.003-1_all.deb ...
Dépaquetage de libmodule-runtime-conflicts-perl (0.003-1) ...
Sélection du paquet libpackage-deprecationmanager-perl précédemment désélectionné.
Préparation du dépaquetage de .../67-libpackage-deprecationmanager-perl_0.17-1_all.deb ...
Dépaquetage de libpackage-deprecationmanager-perl (0.17-1) ...
Sélection du paquet libmoose-perl précédemment désélectionné.
Préparation du dépaquetage de .../68-libmoose-perl_2.2012-2_amd64.deb ...
Dépaquetage de libmoose-perl (2.2012-2) ...
Sélection du paquet libnet-cups-perl précédemment désélectionné.
Préparation du dépaquetage de .../69-libnet-cups-perl_0.64-1build2_amd64.deb ...
Dépaquetage de libnet-cups-perl (0.64-1build2) ...
Sélection du paquet libopenoffice-oodoc-perl précédemment désélectionné.
Préparation du dépaquetage de .../70-libopenoffice-oodoc-perl_2.125-3_all.deb ...
Dépaquetage de libopenoffice-oodoc-perl (2.125-3) ...
Sélection du paquet libsys-cpu-perl précédemment désélectionné.
Préparation du dépaquetage de .../71-libsys-cpu-perl_0.61-2build4_amd64.deb ...
Dépaquetage de libsys-cpu-perl (0.61-2build4) ...
Sélection du paquet libtext-wrapper-perl précédemment désélectionné.
Préparation du dépaquetage de .../72-libtext-wrapper-perl_1.05-2_all.deb ...
Dépaquetage de libtext-wrapper-perl (1.05-2) ...
Sélection du paquet proj-bin précédemment désélectionné.
Préparation du dépaquetage de .../73-proj-bin_6.3.1-1_amd64.deb ...
Dépaquetage de proj-bin (6.3.1-1) ...
Paramétrage de libmodule-pluggable-perl (5.2-1) ...
Paramétrage de libxerces-c3.2:amd64 (3.2.2+debian-1build3) ...
Paramétrage de proj-data (6.3.1-1) ...
Paramétrage de libthrowable-perl (0.200013-1) ...
Paramétrage de libgeos-3.8.0:amd64 (3.8.0-1build1) ...
Paramétrage de libogdi4.1 (4.1.0+ds-1build1) ...
Paramétrage de libcharls2:amd64 (2.0.0+dfsg-1build1) ...
Paramétrage de libsys-cpu-perl (0.61-2build4) ...
Paramétrage de libfilesys-df-perl (0.92-6build4) ...
Paramétrage de libconvert-binhex-perl (1.125-1) ...
Paramétrage de libtbb2:amd64 (2020.1-2) ...
Paramétrage de libemail-messageid-perl (1.406-1) ...
Paramétrage de libarpack2:amd64 (3.7.0-3) ...
Paramétrage de libemail-simple-perl (2.216-1) ...
Paramétrage de libemail-mime-contenttype-perl (1.022-1) ...
Paramétrage de libpq5:amd64 (12.4-0ubuntu0.20.04.1) ...
Paramétrage de libsuperlu5:amd64 (5.2.1+dfsg1-4) ...
Paramétrage de libdap25:amd64 (3.20.5-1) ...
Paramétrage de libqhull7:amd64 (2015.2-4) ...
Paramétrage de libmodule-runtime-conflicts-perl (0.003-1) ...
Paramétrage de libtext-wrapper-perl (1.05-2) ...
Paramétrage de libepsilon1:amd64 (0.9.2+dfsg-4) ...
Paramétrage de libmime-tools-perl (5.509-1) ...
Paramétrage de libaec0:amd64 (1.0.4-1) ...
Paramétrage de gdal-data (3.0.4+dfsg-1build3) ...
Paramétrage de libclass-load-perl (0.25-1) ...
Paramétrage de libcfitsio8:amd64 (3.470-3) ...
Paramétrage de libclass-tiny-perl (1.006-1) ...
Paramétrage de libopenoffice-oodoc-perl (2.125-3) ...
Paramétrage de libgeos-c1v5:amd64 (3.8.0-1build1) ...
Paramétrage de libsocket++1:amd64 (1.12.13-10build1) ...
Paramétrage de libgraphicsmagick-q16-3 (1.4+really1.3.35-1) ...
Paramétrage de libproj15:amd64 (6.3.1-1) ...
Paramétrage de libodbc1:amd64 (2.3.6-0.1build1) ...
Paramétrage de libnet-cups-perl (0.64-1build2) ...
Paramétrage de libhdf4-0-alt (4.2.14-1ubuntu1) ...
Paramétrage de libemail-mime-encodings-perl (1.315-2) ...
Paramétrage de liburiparser1:amd64 (0.9.3-2) ...
Paramétrage de libpackage-deprecationmanager-perl (0.17-1) ...
Paramétrage de libfreexl1:amd64 (1.0.5-3) ...
Paramétrage de libemail-abstract-perl (3.008-2) ...
Paramétrage de libgraphics-magick-perl (1.4+really1.3.35-1) ...
Paramétrage de libfyba0:amd64 (4.1.1-6build1) ...
Paramétrage de libkmlbase1:amd64 (1.3.0-8build1) ...
Paramétrage de libdapclient6v5:amd64 (3.20.5-1) ...
Paramétrage de libdevel-overloadinfo-perl (0.005-1) ...
Paramétrage de auto-multiple-choice-doc (1.4.0+git2020-08-23-1~focal1) ...
Paramétrage de libclass-load-xs-perl (0.10-1build4) ...
Paramétrage de libarmadillo9 (1:9.800.4+dfsg-1build1) ...
Paramétrage de libmoox-types-mooselike-perl (0.29-1) ...
Paramétrage de libdbi-perl:amd64 (1.643-1) ...
Paramétrage de libsz2:amd64 (1.0.4-1) ...
Paramétrage de libemail-address-xs-perl (1.04-1build2) ...
Paramétrage de libkmldom1:amd64 (1.3.0-8build1) ...
Paramétrage de libspatialite7:amd64 (4.3.0a-6build1) ...
Paramétrage de libopencv-core4.2:amd64 (4.2.0+dfsg-5) ...
Paramétrage de libkmlengine1:amd64 (1.3.0-8build1) ...
Paramétrage de libmoose-perl (2.2012-2) ...
Paramétrage de libdevel-partialdump-perl (0.20-1) ...
Paramétrage de libopencv-imgproc4.2:amd64 (4.2.0+dfsg-5) ...
Paramétrage de proj-bin (6.3.1-1) ...
Paramétrage de libgeotiff5:amd64 (1.5.1-2) ...
Paramétrage de libemail-sender-perl (1.300034-1) ...
Paramétrage de libgdcm3.0:amd64 (3.0.5-1.1ubuntu2) ...
Paramétrage de libhdf5-103:amd64 (1.10.4+repack-11ubuntu1) ...
Paramétrage de libemail-mime-perl (1.946-1) ...
Paramétrage de libdbd-sqlite3-perl:amd64 (1.64-1build1) ...
Paramétrage de libnetcdf15:amd64 (1:4.7.3-1) ...
Paramétrage de auto-multiple-choice-common (1.4.0+git2020-08-23-1~focal1) ...
Paramétrage de odbcinst (2.3.6-0.1build1) ...
Paramétrage de odbcinst1debian2:amd64 (2.3.6-0.1build1) ...
Paramétrage de libgdal26 (3.0.4+dfsg-1build3) ...
Paramétrage de libopencv-imgcodecs4.2:amd64 (4.2.0+dfsg-5) ...
Paramétrage de auto-multiple-choice (1.4.0+git2020-08-23-1~focal1) ...
Traitement des actions différées (« triggers ») pour tex-common (6.13) ...
Running mktexlsr. This may take some time... done.
Running mtxrun --generate. This may take some time... done.
Traitement des actions différées (« triggers ») pour shared-mime-info (1.15-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour doc-base (0.10.9) ...
Traitement de 1 fichier de documentation ajouté…
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...

ouin-j@ouinj-Ubuntu:~$ auto-multiple-choice
Can't locate Locale/Language.pm in @INC (you may need to install the Locale::Language module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.30.0 /usr/local/share/perl/5.30.0 /usr/lib/x86_64-linux-gnu/perl5/5.30 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/lib/AMC/perl/AMC-gui.pl line 48.
BEGIN failed--compilation aborted at /usr/lib/AMC/perl/AMC-gui.pl line 48.

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Alexis Bienvenüe 10 days ago

Pas de chance il manquait une dépendance :

sudo apt-get install liblocale-codes-perl

Comment faire pour le lancer depuis le Terminal (pour faire un test) ?

auto-multiple-choice

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

Est-ce que "TexLive" ne serait pas également concerné ?
Je pose la question car lorsque je veux utiliser le package "pythontex" avec TexMaker, j'ai l'erreur suivante :

Traceback (most recent call last): File "/usr/share/texlive/texmf-dist/scripts/pythontex/pythontex.py", line 50, in <module> import pythontex2 as pythontex ImportError: No module named pythontex2

Effectivement lorsque je vais voir dans le dossier indiqué, le fichier "pythontex2.py" a disparu.

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

Cela fonctionne ! AMC est apparu !
Un ENORME MERCI !

ouin-j@ouinj-Ubuntu:~$ sudo apt-get install liblocale-codes-perl
[sudo] Mot de passe de ouin-j : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  liblocale-codes-perl
0 mis à jour, 1 nouvellement installés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de prendre 246 ko dans les archives.
Après cette opération, 2 403 ko d'espace disque supplémentaires seront utilisés.
Réception de :1 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 liblocale-codes-perl all 3.62-1 [246 kB]
246 ko réceptionnés en 0s (631 ko/s)           
Sélection du paquet liblocale-codes-perl précédemment désélectionné.
(Lecture de la base de données... 646127 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../liblocale-codes-perl_3.62-1_all.deb ...
Dépaquetage de liblocale-codes-perl (3.62-1) ...
Paramétrage de liblocale-codes-perl (3.62-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...

Il semblerait que "texlive" ait des paquets manquants vu mon dernier mail.
Un essai : désinstaller texlive et le ré-installer ? (afin de retrouver "pythontex" comme au premier jour)
Qu'en pensez-vous ?

Encore merci.
J/O

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

Voici le contenu du dossier "pythontex"

J/O

AMC_pythontex.png - Liste des fichiers du dossier "pythontex" (30.9 kB)

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Alexis Bienvenüe 10 days ago

C'est normal petit à petit python2 disparaît des paquets debian.

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

Merci pour votre réponse, cela me fait avancer.

Dans Texmaker j'ai la commande :

\usepackage[gobble=auto]{pythontex}

Que dois-je faire de plus à votre avis ?

1/ Installer Python3 ? Mais je crois qu'il est déjà installé sur mon PC.

Je sais que cela ne concerne pas directement AMC mais si vous avez une idée je suis preneur.

J/O

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

J'ai ceci dans le Terminal lorsque je tape "python3" :

ouin-j@ouinj-Ubuntu:~$ python3
Python 3.8.5 (default, Jul 28 2020, 12:59:40) 
[GCC 9.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

Et le paquet "texlive-extra-utils" semble à jour dans Synaptic :
(capture)

texlive.png - Capture Synaptic : textlive-extra-utils (25.1 kB)

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Gérard Carpeaux 10 days ago

Bonjour,
Pouvez-vous résumer votre méthode pour le collègue https://project.auto-multiple-choice.net/boards/3/topics/10194, je ne sais pas s'il a réussi.

Pour global, dans le doc de pythontex, il est écrit que les espaces alinéalisées (y a pas de raison de ne pas inventer des mots comme les anglo-saxons) sont effacés mais que ça peut coincer.

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Alexis Bienvenüe 10 days ago

Comment appelez-vous pythontex ?
Si c'est avec une commande du genre

python /usr/share/texlive/texmf-dist/scripts/pythontex/pythontex.py $AMC_JOBNAME.pytxcode

il doit suffire de la remplacer par

python3 /usr/share/texlive/texmf-dist/scripts/pythontex/pythontex.py $AMC_JOBNAME.pytxcode

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

Oui OK, je vais résumer la méthode pour le collègue. Avec plaisir.

Pour ce qui est de pythontex, effectivement il faut que je modifie mes "commandes utilisateur". Je regarde et reviens donner un retour.
J/O

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Alexis Bienvenüe 10 days ago

Autre solution : dire au système que la commande python doit appeler python3 et non python2 comme actuellement. Mais cela impactera tout ce qui appelle la commande python et pas seulement AMC, bien sûr.

https://www.framboise314.fr/raspbian-python-3-par-defaut-et-arret-propre-par-bouton-poussoir/

RE: Versions d'AMC avec Ubuntu 18.04 et 20.04 ? - Added by Joss OUIN 10 days ago

OK, cela fonctionne :
J'ai modifié ainsi la commande utilisateur dans Texmaker :

pdflatex --shell-escape -synctex=1 -interaction=nonstopmode %.tex|
python3 /usr/share/texlive/texmf-dist/scripts/pythontex/pythontex3.py %.tex|
pdflatex --shell-escape -synctex=1 -interaction=nonstopmode %.tex|

Remarque :
Cela ne fonctionne pas si je ne pointe par vers "pythontex3.py"

Pour comparaison, voici la commande utilisateur avec la version 18.04 d'Ubuntu.

pdflatex --shell-escape -synctex=1 -interaction=nonstopmode %.tex|
python /usr/share/texlive/texmf-dist/scripts/pythontex/pythontex.py %.tex|
pdflatex --shell-escape -synctex=1 -interaction=nonstopmode %.tex|

En espérant que cela puisse servir.

Encore merci Alexis pour votre aide et votre disponibilité.
Belle soirée à vous.
J/O

(1-22/22)