Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex"

Added by Laurent Mon 29 days ago

Bonjour,
Pour pouvoir afficher du code python, j'utilise le package minted avec \usepackage{minted}
J'avais eu des problèmes pour y arriver sur le forum j'ai eu comme solution "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex"
Cette commande a été utilisé dans texmaker. Cela fonctionne bien, mais dans AMCquand je veux créer 30 sujets le problème réapparait.
Où dois-je mettre cette commande pour que AMC compile les sujets avec ?
Merci pour votre aide.


Replies (8)

RE: Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex" - Added by Gérard Carpeaux 28 days ago

Dans la doc, à la partie Conflits avec d’autres paquets, sous-partie Import de fichiers externes, il est écrit

\inputminted{python}{prog.py}
prog.py
est un fichier copié dans le répertoire du projet.
Je ne sais pas si cela répond à votre question.
J'ai tapé cette partie de documentation mais c'était un utilisateur anglophone qui avait fait un tuto sur le forum si je ne dis pas de bétises.

RE: Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex" - Added by Laurent Mon 28 days ago

Merci pour votre réponse,

Mes programmes sont dans un dossier algo
J'appelle donc ces programmes ainsi:

\inputminted{python}{algo/prog.py}

Et cela fonctionne correctement avec Texmaker,le problème arrive quand je génère 30 copies avec AMC.
J'essierai en mettant les fichiers .py dans le même dossier dès que jerentre.

RE: Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex" - Added by Alexis Bienvenüe 28 days ago

Où dois-je mettre cette commande pour que AMC compile les sujets avec ?

Vous pouvez mettre la valeur

pdflatex -shell-escape

dans l'option de configuration Préférences/Projet/Commandes utilisées/Moteur LaTeX

RE: Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex" - Added by Laurent Mon 27 days ago

Merci pour votre réponse,
Placer la commande dans le moteur latex n'a pas résolu le problème.

pdflatex -shell-escape

J'ai contourné le problème en faisant des captures d'écran des scripts python et donc en les considérant comme des images.
Cela m'a permis de faire passer l'examen à mes élèves aujourd'hui.
Je regrette d'avoir changé d'ordinateur !! pourtant l'installation est propre et AMC s'est installé sans souci.
Je vais poursuivre mes essais pour le prochain devoir.

RE: Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex" - Added by Gérard Carpeaux 22 days ago

Pouvez-vous essayer en installant le module python-pygments s'il n'est pas installé ?

RE: Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex" - Added by Laurent Mon 16 days ago

Bonjour,
Désolé pour la réponse tardive, mais le sujet que j'avais composé n'était plus accessible.

En effet le module python-pygments n'étaient installés sur cet ordinateur.
Mon sujet a pu être compilé par AMC.
Je pense que le problème venait donc de là.

Merci pour votre aide

RE: Problème avec "pdflatex -synctex=1 -interaction=nonstopmode --shell-escape %.tex" - Added by Gérard Carpeaux 14 days ago

Chez moi, cela ne fonctionne pas. Comment avez-vous installé le module pygments (synaptic, pip) ?

(1-8/8)