Problème installation sur OSX 10.14

Added by Patrick Aymar 6 months ago

J'ai déjà posté, à tort, sur le forum d'utilisation.
J'ai tenté une mise à jour de AMC et je suis passé de macport à Homebrew avec https://github.com/maelvalais/homebrew-amc. (j'ai posté aussi sur le dépôt ne sachant pas à quel niveau se situe le problème).
L'installation de AMC et de mactex se passe sans erreur mais cela bloque lorsque je lance sudo auto-multiple-choice latex-link

Can't load '/usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/auto/Glib/Glib.bundle' for module Glib: dlopen(/usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/auto/Glib/Glib.bundle, 1): Library not loaded: /usr/local/opt/gettext/lib/libintl.8.dylib
  Referenced from: /usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/auto/Glib/Glib.bundle
  Reason: image not found at /usr/local/Cellar/perl/5.28.1/lib/perl5/5.28.1/darwin-thread-multi-2level/DynaLoader.pm line 197.
 at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/Cairo/GObject.pm line 15.
Compilation failed in require at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/Cairo/GObject.pm line 15.
BEGIN failed--compilation aborted at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/Cairo/GObject.pm line 15.
Compilation failed in require at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/Gtk3.pm line 47.
BEGIN failed--compilation aborted at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/Gtk3.pm line 47.
Compilation failed in require at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/lib/AMC/perl/AMC-gui.pl line 23.
BEGIN failed--compilation aborted at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/lib/AMC/perl/AMC-gui.pl line 23.

J'ai ressayé de passer sur macport mais j'ai des erreurs de tar et de fonts non trouvées :
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/main.log en pièce jointe.

xxpa.txt (525.4 kB)


Replies (3)

RE: Problème installation sur OSX 10.14 - Added by Patrick Aymar 6 months ago

J'ai avancé dans mon installation avec homebrew et https://github.com/maelvalais/homebrew-amc et l'aide du développeur.
Le problème ci-dessus etait un problème de droits sur /usr/local, certains répertoire appartenaient à root.

Il reste un problème au lancement de AMC avec un WARNING qui bloque l'exécution :

(AMC-gui.pl:44395): Gtk-WARNING **: 09:12:50.120: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
Failed to load /usr/local/Cellar/auto-multiple-choice/1.4.0_1/share/auto-multiple-choice/icons/auto-multiple-choice.svg: Unrecognized image file format at /usr/local/Cellar/auto-multiple-choice/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/Glib/Object/Introspection.pm line 67.

L'icône existe et semble avoir les bons droits, j'imagine que c'est un problème de mime.

RE: Problème installation sur OSX 10.14 [RESOLU] - Added by Patrick Aymar 6 months ago

Problème résolu.
L'ensemble était lié aux droits sur /usr/local.

RE: Problème installation sur OSX 10.14 - Added by Patrick Aymar 6 months ago

Je ne peux pas mettre à jour ma réponse mais le problème n'est pas résolu.
Il y a un problème avec le navigateur de fichier :

$ /usr/local/bin/auto-multiple-choice

(AMC-gui.pl:68979): GLib-GIO-ERROR **: 09:07:00.357: No GSettings schemas are installed on the system
Trace/BPT trap: 5

Cela plante perl.
J'ai avant cela, au lancement de AMC, un message non bloquant (cf pj).

(1-3/3)