Problème de reconnaissance des scans

Added by Miguel Concy about 1 year ago

Bonjour
J'ai installé la version d'AMC avec Homebrew.
J'ai fabriqué un questionnaire AMC, scanné les deux pages de réponses...
qui sont corrigées correctement sur une autres machine que la mienne mais pas chez moi.
En pièce-jointe, les pièces qui sont demandées dans la rubrique "Bug Report" de l'aide à une exception près.
Je n'ai joint de config log... puisque je n'ai pas réussi à le localiser sur ma machine.
Merci pour toute réponse
Miguel


Replies (5)

RE: Problème de reconnaissance des scans - Added by Maël Valais about 1 year ago

Coucou,
Je jetterai un coup d’œil demain. Merci pour le zip pour reproduire le bug !

RE: Problème de reconnaissance des scans - Added by Maël Valais about 1 year ago

Ça a l'air de marcher correctement sur la v1.3.0.2199_1. Je vois dans le log que vous avez la version 1.3.0.2199. Serait-il possible de faire brew upgrade auto-multiple-choice puis réessayer ?

Je n'ai pas vraiment trouvé d'infos dans le log ; qu'entendez-vous par qui sont corrigées correctement sur une autres machine que la mienne mais pas chez moi. ? Quel est le comportement ? Quand vous appuyez sur "Corriger", il ne se passe rien ?

RE: Problème de reconnaissance des scans - Added by Alexis Bienvenüe about 1 year ago

Je n'ai pas vraiment trouvé d'infos dans le log

Je pense que le (premier) passage intéressant est ici, mais je ne sais pas trop ce que cela signifie :

Reading scan /Users/mconcy/MC-Projects/test_AMC_Miguel/scans/Mon_Scan.pdf-page-0001_0000.pdf.png for extractions...
Can't load '/usr/local/Cellar/auto-multiple-choice/1.3.0.2199/libexec/lib/perl5/darwin-thread-multi-2level/auto/Image/Magick/Magick.bundle' for module Image::Magick: dlopen(/usr/local/Cellar/auto-multiple-choice/1.3.0.2199/libexec/lib/perl5/darwin-thread-multi-2level/auto/Image/Magick/Magick.bundle, 1): Library not loaded: /usr/local/opt/imagemagick@6/lib/libMagickCore-6.Q16.5.dylib
  Referenced from: /usr/local/Cellar/auto-multiple-choice/1.3.0.2199/libexec/lib/perl5/darwin-thread-multi-2level/auto/Image/Magick/Magick.bundle
  Reason: image not found at /usr/local/Cellar/perl/5.26.2/lib/perl5/5.26.2/darwin-thread-multi-2level/DynaLoader.pm line 197.
\00 at /usr/local/Cellar/perl/5.26.2/lib/perl5/5.26.2/Module/Load.pm line 77.
Compilation failed in require at /usr/local/Cellar/perl/5.26.2/lib/perl5/5.26.2/Module/Load.pm line 77.
Can't locate Image/Magick in @INC (@INC contains: /usr/local/Cellar/auto-multiple-choice/1.3.0.2199/libexec/lib/perl5/darwin-thread-multi-2level /usr/local/Cellar/auto-multiple-choice/1.3.0.2199/libexec/lib/perl5 /usr/local/Cellar/perl/5.26.2/lib/perl5/site_perl/5.26.2/darwin-thread-multi-2level /usr/local/Cellar/perl/5.26.2/lib/perl5/site_perl/5.26.2 /usr/local/Cellar/perl/5.26.2/lib/perl5/5.26.2/darwin-thread-multi-2level /usr/local/Cellar/perl/5.26.2/lib/perl5/5.26.2 /usr/local/lib/perl5/site_perl/5.26.2/darwin-thread-multi-2level /usr/local/lib/perl5/site_perl/5.26.2) at /usr/local/Cellar/perl/5.26.2/lib/perl5/5.26.2/Module/Load.pm line 77.
&Image::Magick::constant not defined. The required ImageMagick libraries are not installed or not installed properly.
END failed--call queue aborted.

RE: Problème de reconnaissance des scans - Added by Maël Valais about 1 year ago

Ah, ok ! Le message

Library not loaded: /usr/local/opt/imagemagick@6/lib/libMagickCore-6.Q16.5.dylib

correspond bien à un souci (nouvelle version de ImageMagick chez Homebrew) que j'ai réglé avec la 1.3.0.2199_1.

RE: Problème de reconnaissance des scans - Added by Miguel Concy about 1 year ago

ça marche !
J'ai fait la mise-à-jour Brew et avec la version 1.3.0.2199_1 ça reconnaît les scans...
Maintenant je me penche sur la notation.
merci beaucoup, Maël et Alexis, pour l'efficacité de votre intervention.
Miguel

(1-5/5)