AMC 1.3 Build impossible (Mac OSX)

Added by s swurm about 6 years ago

Bonjour,

Je suis désemparé car je ne parviens plus à installer AMC suite à une désinstallation...

Voici ce que donne le "sudo port install"... Que faire ?

--->  Computing dependencies for auto-multiple-choice-devel
--->  Fetching archive for auto-multiple-choice-devel
--->  Attempting to fetch auto-multiple-choice-devel-1.3.0.2134_0.darwin_17.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/auto-multiple-choice-devel
--->  Attempting to fetch auto-multiple-choice-devel-1.3.0.2134_0.darwin_17.x86_64.tbz2 from https://packages.macports.org/auto-multiple-choice-devel
--->  Attempting to fetch auto-multiple-choice-devel-1.3.0.2134_0.darwin_17.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/auto-multiple-choice-devel
--->  Fetching distfiles for auto-multiple-choice-devel
--->  Attempting to fetch 74c619d2a6ac.tar.gz from https://bitbucket.org/auto-multiple-choice/auto-multiple-choice/get
--->  Verifying checksums for auto-multiple-choice-devel                             
--->  Extracting auto-multiple-choice-devel
--->  Configuring auto-multiple-choice-devel
--->  Building auto-multiple-choice-devel
Error: Failed to build auto-multiple-choice-devel: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice-devel/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port auto-multiple-choice-devel failed


Replies (24)

RE: AMC 1.3 Build impossible (Mac OSX) - Added by s swurm about 6 years ago

J'ai mis la version pour devel, mais c'est pareil pour la version stable. Je précise que je suis sous High Sierra et que Macports est à jour... a priori.

MacBook-Air-de-Stephane:~ stephane$ sudo port install auto-multiple-choice
Password:
--->  Computing dependencies for auto-multiple-choice
--->  Building auto-multiple-choice
Error: Failed to build auto-multiple-choice: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port auto-multiple-choice failed

RE: AMC 1.3 Build impossible (Mac OSX) - Added by s swurm about 6 years ago

Voici le contenu du log (désolé pour les messages multiples)

:error:build Failed to build auto-multiple-choice-devel: command execution failed
:debug:build Error code: CHILDSTATUS 2463 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring" 
:debug:build     invoked from within
:debug:build "command_exec build" 
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname" 
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice-devel/main.log for details.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by s swurm about 6 years ago

Quand la porte est fermé, on entre par la fenêtre...

J'ai résolu le problème en installant Ubuntu sur Virtualbox... LOL.

Bref, je vais faire comme ça en attendant.
Et j'ai enfin la 1.3 qui gère les groupes de question !!!!

RE: AMC 1.3 Build impossible (Mac OSX) - Added by s swurm about 6 years ago

Alexis Bienvenue, si tu passes par ici, confirmes-tu que AMC 1.3 est compatible avec High Sierra ?? Auquel cas, c'est mon mac qui a un problème...

Bref, j'ai contourné l'obstacle.

Et merci surtout pour ce super logiciel.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Alexis Bienvenüe about 6 years ago

confirmes-tu que AMC 1.3 est compatible avec High Sierra ?

Pour tout ce qui touche à MacOSX, ce n'est pas à moi qu'il faut demander…

RE: AMC 1.3 Build impossible (Mac OSX) - Added by s swurm about 6 years ago

Alexis Bienvenüe wrote:

confirmes-tu que AMC 1.3 est compatible avec High Sierra ?

Pour tout ce qui touche à MacOSX, ce n'est pas à moi qu'il faut demander…

Entendu. Je comprends !...

Et désolé pour avoir oublié le tréma !

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Joël Brogniart about 6 years ago

AMC fonctionne bien sous macOS High Sierra.

Pouvez-vous fournir le journal de la tentative d'installation ?

RE: AMC 1.3 Build impossible (Mac OSX) - Added by s swurm about 6 years ago

Joël Brogniart wrote:

AMC fonctionne bien sous macOS High Sierra.

Pouvez-vous fournir le journal de la tentative d'installation ?

Bonjour,

Je suis vraiment désolé. De rage, j'ai supprimé Xcode... Je n'ai pas beaucoup de temps pour voir ça pour l'instant car je suis en plein dans une session d'examen.
Pour l'instant, le problème est réglé pour moi avec la solution de Virtualbox.

Merci pour votre aide malgré tout !

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Philippe LAMARRE about 6 years ago

s swurm wrote:

Bonjour,

Je suis désemparé car je ne parviens plus à installer AMC suite à une désinstallation...

Voici ce que donne le "sudo port install"... Que faire ?

[...]

Bonjour à tous,

Avant tout merci pour ce logiciel qui m'est bien utile.

Mais il semblerait que j'ai le même problème. Jusque là j'étais en version 1.2.1 et je souhaitais passer en 1.3… Bilan : plus rien de fonctionne !

Message obtenu :

-----------------------------
Machine$ sudo port upgrade outdated
Password:
---> Computing dependencies for auto-multiple-choice
---> Building auto-multiple-choice
Error: Failed to build auto-multiple-choice: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

En attaché, le fichier de log.

Toute aide est la bien venue ! Ça va bientôt devenir urgent.

Merci.

main.log (287.7 kB)

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Joël Brogniart about 6 years ago

Pouvez-vous vérifier si en suivant les instructions de Installation_d'AMC_sous_macOS l'installation marche ?

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Jose Goicolea about 6 years ago

Je trouve le meme erreur sur mac osx. Pendant un "port update" auto-multiple-choice-devel ne s'installe plus. J'ai suivi les instructions pour l'installation mais ça ne marche pas:

---> Computing dependencies for auto-multiple-choice-devel
---> Building auto-multiple-choice-devel
Error: Failed to build auto-multiple-choice-devel: command execution failed
Error: See /opt/local/var/macports/logs/_Users_goico_nix_macports_x11_auto-multiple-choice-devel/auto-multiple-choice-devel/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port auto-multiple-choice-devel failed

J'attache le log file. Merci

main.log - log file with errors (885 kB)

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Matthias Dorn about 6 years ago

Merci pour votre participation et vos améliorations.
J'ai passé plusieurs jours à installer AMC sans succès.
La description "Problème installation AMC sous Mac OS 10.13 (Support #517)"
m'a beaucoup aidé. Mais je suis arrivé à installer AMC uniquement après avoir installé:
une nouvelle version de Xcode 9.2 (j'ai donc remplacé l'ancienne version)
L'installation s'est bien effectuée avec MacOsX 10.11 ; 10.12. Avec 10.13 j'arrive comme vous à l'Erreur ajouté par Jose Goicolea.
j'ai donc énormément progressé.
Il reste à résoudre cette erreur.
avec 10.12 par-contre la même procédure fonctionne très bien et AMC fonctionne.

Merci
content de vous lire.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Joël Brogniart about 6 years ago

Avez vous bien suivi les instructions concernant Perl ?

@Jose Goicolea : il semble que les outils docbook ne sont pas installés. Il faudrait installer le port dblatex.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Jose Goicolea about 6 years ago

Merci beaucoup de votre réponse,
oui, j'ai bien fait

sudo port install perl5 +perl5_26
...
sudo port install dblatex

mais j'arrive au même erreur. (C'est sur macOS High Sierra 10.13.2, xcode version 9.2 (9.C40b)

RE: AMC 1.3 Build impossible (Mac OSX) - Added by s swurm about 6 years ago

Jose Goicolea wrote:

Merci beaucoup de votre réponse,
oui, j'ai bien fait
[...]
mais j'arrive au même erreur. (C'est sur macOS High Sierra 10.13.2, xcode version 9.2 (9.C40b)

Bonjour,

Je me souviens d'avoir fait aussi ces deux commandes, qui n'aboutissaient pas.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Joël Brogniart about 6 years ago

Bon, je viens de faire les étapes suivantes sous macOS 10.13.2, Macports 1.4.2, Xcode 9.2.

Nettoyage des ports pour partir d'une installation propre.

sudo port uninstall installed

Mise à jour Macports

sudo port selfupdate

Installation Perl 5.26

sudo port install perl5 +perl5_26

Installation AMC

sudo port install auto-multiple-choice

L'installation s'est bien passée et AMC fonctionne. Je n'arrive pas à reproduire le problème.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Joël Brogniart about 6 years ago

Et je viens de faire la même choses pour le port auto-multiple-choice-devel. Là aussi l'installation s'est bien passée.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Jose Goicolea about 6 years ago

merci, j'ai arrivé a le faire installer! c'était seulement un problème pour générer la documentation, avec "docbook.sty". Il fallait dans mon cas seulement installer a nouveau dblatex:

 sudo uninstall dblatex;sudo install dblatex

après ça l'installation marche parfaitement. Merci beaucoup de votre aide!

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Philippe LAMARRE about 6 years ago

Bonjour,

De mon côté, problème persistant :

Éléments réalisés :
sudo port uninstall auto-multiple-choice
sudo port selfupdate
sudo port upgrade outdated
sudo port install auto-multiple-choice

Même problème. Conclusion, ça vient d’autre chose !

Recherche dans le log —> des erreurs apparaissent sur les polices de caractère !
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found
:info:build make1: *** [auto-multiple-choice.en.ext] Error 2
etc.
:info:build ! fontspec error: "font-not-found"
:info:build ! fontspec error: "font-not-found"
Conclusion : problème de police plausible !

Vérification : les polices Libertine et DéjàVu ne sont pas présentes !

Tentative de téléchargement :
La police Linux Libertine
http://www.linuxlibertine.org/index.php?id=1&L=1
Site web en rade —>
Strict Standards: Non-static method t3lib_div::getClassName() should not be called statically in /usr/share/php/typo3_src-4.3.14/t3lib/class.t3lib_div.php on line 5033

Fatal error: Uncaught exception 't3lib_error_Exception' with message 'PHP Runtime Notice: Non-static method t3lib_div::getClassName() should not be called statically in /usr/share/php/typo3_src-4.3.14/t3lib/class.t3lib_div.php line 5033' in /usr/share/php/typo3_src-4.3.14/t3lib/error/class.t3lib_error_errorhandler.php:106 Stack trace: #0 /usr/share/php/typo3_src-4.3.14/t3lib/class.t3lib_div.php(5033): t3lib_error_ErrorHandler->handleError(2048, 'Non-static meth...', '/usr/share/php/...', 5033, Array) #1 /usr/share/php/typo3_src-4.3.14/t3lib/class.t3lib_div.php(5033): t3lib_div::getClassName() #2 /usr/share/php/typo3_src-4.3.14/typo3/sysext/cms/tslib/index_ts.php(143): t3lib_div::makeInstance('t3lib_error_Pro...') #3 /usr/share/php/typo3_src-4.3.14/index.php(80): require('/usr/share/php/...') #4 {main} thrown in /usr/share/php/typo3_src-4.3.14/t3lib/error/class.t3lib_error_errorhandler.php on line 106

C’est mort de ce côté !
La famille de polices DejaVu
https://dejavu-fonts.github.io/wiki/Download
Erreur 404

Bon, ben comment dire !
Ces deux polices ne sont plus accessibles… ceux qui les ont déjà peuvent certainement installer, pour les autres comme moi, ça peut être une cause de problème ?

Question : le manque de ces deux policies est-il un point bloquant pour l’installation ? Si oui, où est-il possible de les récupérer ?

Merci et à bientôt
Philippe

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Jose Goicolea about 6 years ago

Pour linux libertine j'ai pu l'installer d'ici:

https://sourceforge.net/projects/linuxlibertine/

après il faut les placer sur le /Library/Fonts folder

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Matthias Dorn about 6 years ago

Pour DejaVu j'ai utilisé:
https://dejavu-fonts.github.io/Download.html
a placer dans le /Library/Fonts folder

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Matthias Dorn about 6 years ago

J'ai finalement réussi à installer avec succès AMC sur Mac OSX 10.13.2.
Pour réussir j'ai fait en plus des indications mentionnées au-dessus:
1) vérifier les polices avec le livre de polices. Ce logiciel pointait sur des doublons pour les fontes DejaVu.
2) J'ai donc viré totalement tous ces fontes pour les réinstaller proprement.
je retient donc comme mode d'installation:
Suivre scrupuleusement les indications d'installation.
En commençant par un nettoyage de tous les logiciels (Macport, XQuartz, les polices (mettre à jours les fontes et vérifier leurs validité (Livre des polices.app)les installer dans le bon fichier) installer la nouvelle version de Xcode.
puis en suivant la procédure de Joël Brogniart ( voir au-dessus)
sudo port uninstall installed
Mise à jour Macports
sudo port selfupdate
Installation Perl 5.26
sudo port install perl5 +perl5_26
Installation AMC
sudo port install auto-multiple-choice

Merci à tous.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Philippe LAMARRE about 6 years ago

Bonjour,

J'ai moi aussi réussi à installer.

Identification du problème : les deux sites référencés pour les polices ne sont plus accessibles.

Solution :

1. - installation manuelle des polices

1.1. - Téléchargements en utilisant une source alternative (sourceforge)

- police libertine : https://sourceforge.net/projects/linuxlibertine/
ce sont des otf
- police dejaVU : https://sourceforge.net/projects/dejavu/?source=typ_redirect/
ce sont des ttf

1.2. - Déplacement dans le répertoire des fonts et vérification des droits

  1. déplacement des fonts dans le bon répertoire
    mv ~/Downloads/LinuxLibertine/LinLibertineOTF_5.3.0_2012_07_02/*.otf /Library/Fonts/
    mv ~/Downloads/dejavu-fonts-ttf-2.37/ttf/DejaVu*.ttf /Library/Fonts/
  1. Vérifier que les droits sont bien les mêmes pour ces nouveaux venus que pour les anciens
  2. (normalement le stick bit fait bien les choses, mais ça ne coûte pas grand-chose de vérifier)
    ls -al /Library/Fonts
    ls -al /Library/Fonts/Lin*.otf
    ls -al /Library/Fonts/DejaVu*.ttf
  3. Si une différence est constatée, changer les droits (commande chmod)

2 - Reprise de l'installation

2.1 Nettoyage des anciennes installations
PAS LA PEINE DE DÉSINSTALLER TOUS LES LOGICIELS GÉRÉS PAR PORT
C'est une précaution de luxe. Normalement, port gère ça très bien, mais…

sudo port uninstall auto-multiple-choice dblatex perl5 +perl5_26

2.2 Mise à jour de port - ça ne peut faire que du bien

sudo port selfupdate
sudo port upgrade outdated

2.3 Installation de auto-multiple-choice
Maintenant que les bases sont saines çà devrait bien se passer

  1. installation des dépendances
    sudo port install dblatex perl5 +perl5_26
  2. installation de port
    sudo port install auto-multiple-choice

C'est fini !

Bonne journée à tous.

RE: AMC 1.3 Build impossible (Mac OSX) - Added by Abdolhakim Shouman 7 months ago

Bonjour,
Pourriez vous m'aider svp pour réussir l'installation de AMC sur mon Max ?
Je serai vraiment réconaissant

(1-24/24)