Installation sous Debian (wheezy)

Added by Lorenzo Miguel almost 7 years ago

Bonjour,

J'ai quelques soucis concernant l'installation de AMC sous Linux. Voici le cheminement que j'ai fait pour l'instant.

Pour pouvoir installer la dernière version, j'ai téléchargé le source, puis installé les packages qu'il me demandait (libopencv, librsvg, libxml2*) et lors du lancement, il me faisait des erreurs perl, j'ai donc installé pas mal de packages du type XML::LibXML et au final, ca ne marchait toujours pas.

J'ai donc décidé d'installer la 1.1 via apt-get install pour obtenir les packages manquants. Une fois ceci fait, j'ai enlevé auto-multiple-choice, auto-multiple-choice-common et auto-multiple-choice-doc, via apt-get remove, puis j'ai installé la nouvelle version 1.2 via le source.

Ca semble être OK jusqu'à ce que je tente d'ouvrir un projet existant puis de faire Update Documents. La, je lis dans la console :
"Unable to open amc-compiled.amc: No such file or directory at /usr/lib/AMC/perl/AMC-prepare.pl line 227."

J'ai également tenté de laisser la 1.1, même problème.

Une idée?

Merci,
Lorenzo


Replies (8)

RE: Installation sous Debian (wheezy) - Added by Alexis Bienvenüe almost 7 years ago

Pour reconstruire le paquet AMC en version 1.2.1 sous wheezy, voici une procédure possible :
  1. Ajouter un fichier /etc/apt/sources.list.d/testing.list avec le contenu suivant :
    deb http://ftp.fr.debian.org/debian/ testing main
    deb-src http://ftp.fr.debian.org/debian/ testing main
    
  2. Si la directive n'est pas encore utilisée, ajouter un fichier /etc/apt/apt.conf.d/90release avec le contenu suivant :
    APT::Default-Release "wheezy";
    
  3. Mettre à jour la liste des paquets disponibles :
    sudo apt-get update
    
  4. Installer les dépendances pour la construction du paquet :
    sudo apt-get build-dep auto-multiple-choice=1.2.1-1
    
  5. Construction :
    sudo apt-get -b source auto-multiple-choice=1.2.1-1
    
  6. Installer (la première commande dit qu'il manque des dépendances, la deuxième les installe)...
    sudo dpkg -i auto-multiple-choice*.deb
    sudo apt-get -f install
    

Si vous êtes en amd64, j'ai mis à tout hasard les fichiers produits dans l'espace de téléchargement.

Ca semble être OK jusqu'à ce que je tente d'ouvrir un projet existant puis de faire Update Documents. La, je lis dans la console :
"Unable to open amc-compiled.amc: No such file or directory at /usr/lib/AMC/perl/AMC-prepare.pl line 227."

Pouvez-vous refaire le test en mode débogage (à partir du menu Aide), et poster le fichier log produit ? Avec le fichier source, ce serait même encore mieux.

RE: Installation sous Debian (wheezy) - Added by Lorenzo Miguel almost 7 years ago

Bonjour,

Voici le log et le répertoire source. Il semblerait que le main.tex n'arrive pas à compiler sous AMC même si avec un pdflatex il n'y a pas de soucis. Le message est le suivant :

! LaTeX Error: \usepackage before \documentclass.

Alors que \documentclass est bien placé avant \usepackage.

AMC-DEBUG-VLfRtunh.log - Log file (9.5 kB)

testrun.tar.gz - Projet (6.6 kB)

RE: Installation sous Debian (wheezy) - Added by Laurent Michel almost 7 years ago

Oh ! Un homonyme ...
++
LM

RE: Installation sous Debian (wheezy) - Added by Alexis Bienvenüe almost 7 years ago

! LaTeX Error: \usepackage before \documentclass.

On voit dans les options de votre projet que le fichier source indiqué à AMC est preamble.tex, alors qu'il devrait être main.tex.

RE: Installation sous Debian - Added by Maximilian Hasler almost 4 years ago

Bonjour,
pour ne pas créer un nouveau thread je m'y mets ici ... car c'est aussi un pb d'installation (je crains) sur la debian.
Plus précisément, l'installation était a priori aisée, avec un simple
apt-get install auto-multiple-choice
Le logiciel démarre sans problème (dans l'environnement gnome), mais il plante dès qu'on crée un Nouveau Projet, que ce soit à partir d'un modèle existant ou à partir d'un fichier .txt en format AMC-TXT: C'est justement au moment du choix de ce fichier (ou un modèle/exemple fourni) que le GUI plante, il ne répond tout simplement plus.
(Lors du premier démarrage il y avait aussi un message d'erreur "canberra-gtk-module manquant", qui n'a cependant pas empêché le GUI de s'afficher et de permettre la création d'un nouveau projet, jusqu'au choix du fichier source où il y a eu plantage. Après installation manuelle du "libcanberra-gtk-module" cette erreur a disparu.)

Merci d'avance si qn aurait une indication...
M.

RE: Installation sous Debian (wheezy) - Added by Alexis Bienvenüe almost 4 years ago

Pouvez-vous activer le mode débogage (depuis le menu Aide) avant de créer un nouveau projet, et joindre le fichier log obtenu ?)

RE: Installation sous Debian (wheezy) - Added by Maximilian Hasler almost 4 years ago

Bonjour,
et merci pour le retour rapide. Ci-joint le fichier "debug" que j'obtiens comme suit:
- lancement de AMC
- Projet → Nouveau
- Choisir le repertoire => je vais dans "QCM" et fais [Valider] (*)
- J'entre le Nom du projet: "QCM-test-001", je clique [Créer un projet]
- Choix du source; je chiosis "modèle" [Suivant], puis "[FR] Documentation" > "Exemple simple au format AMC-TXT" + [Appliquer]

et là ça plante.

(*) Update: je crois que c'est ce choix du répertoire qui est le problème.
Le répertoire est sur un lecteur réseau, mais il a bien crée dans ce lecteur réseau le répertoire "QCM-test-001" et là-dedans les dossiers cr/ data/ exports/ scans/
et les fichiers description.xml options.xml simple-txt.txt

NB: si je choisis comme source au lieu de "modèle" l'option "fichier", puis mon fichier, il crée les dossiers cr/ data/ exports/ scans/ , mais pas les fichiers description.xml options.xml simple-txt.txt

En fait, si je crée le projet sur le disque /home natif (dans Projets-QCM), cela semble fonctionner.
Par contre, il ne peut pas compiler, il dit que xetex n'est pas installé (bug n° 2),
et si je change dans les Préférences le moteur latex en "pdftex", la même erreur persiste,
en fait quand je retourne dans les Préférences le champ "moteur latex" est alors vide, et j'ai beau remettre "pdflatex", dès que je reviens, c'est toujours vide, et il essaie d'utiliser "xetex". (bug n° 3)
Alors que ça mouline un petit moment lorsque je change l'option en pdflatex,
et dans le fichier options.xml il y a bien <moteur_latex_b>xelatex</moteur_latex_b> !

Mais en installant à la main "texlive-xetex" cela fonctionne enfin (mais seulement avec un répertoire sur le disque home en ext3fs, le plantage persiste pour création d'un dossier sur un disque réseau monté en SMB/CIFS).

Je pense que l'analyse / élimination de ces 3 bugs distincts serait quand même précieuse !
Bon courage (je reste dispo pour aider...)
M.

RE: Installation sous Debian (wheezy) - Added by Alexis Bienvenüe almost 4 years ago

Le répertoire est sur un lecteur réseau

Quel genre de lecteur réseau est-ce ?

il dit que xetex n'est pas installé (bug n° 2)
quand je retourne dans les Préférences le champ "moteur latex" est alors vide, et j'ai beau remettre "pdflatex", dès que je reviens, c'est toujours vide, et il essaie d'utiliser "xetex". (bug n° 3)

L'utilisation du format AMC-TXT nécessite l'utilisation de xelatex : si vous utilisez ce format, c'est xelatex qui sera utilisé quelle que soit votre configuration. Le fichier AMC-TXT sera transformé en un fichier LaTeX qui ne peut être compilé qu'avec xelatex.

Mais en installant à la main "texlive-xetex" cela fonctionne enfin

C'est effectivement la bonne solution.

(1-8/8)