Installation d'AMC sous OS X

Added by Joël Brogniart about 7 years ago

L'installation d'AMC à partir de MacPorts a été mis à jour avec la version 1.2.1. L'installation s'en trouve simplifiée et la documentation du wiki a été mise à jour.


Replies (9)

RE: Installation d'AMC sous OS X - Added by Hervé Cabaud almost 7 years ago

Bonjour,
est-ce que quelqu'un a testé le passage sous mac os 10.9 ( maverick ? ) ?
Je ne voudrais pas saborder ami par une mise à jour inappropriée vu mes capacités…
Merci

RE: Installation d'AMC sous OS X - Added by Joël Brogniart almost 7 years ago

Bonjour,

Je suis passé sous Mavericks (10.9) mais je n'ai pas encore eu le temps de tester si tout fonctionne. Normalement il est conseillé, à chaque changement majeur d'OS X, de désinstaller totalement MacPorts et de réinstaller la version adaptée à la nouvelle version d'OS X. Ça bouge encore pas mal pour l'instant et j'ai une pile de boulot un peu encombrée. J'essaie de caser l'installation de la nouvelle version de MacPorts (nouvelle version de Xcode déjà installée) dans la semaine prochaine. Je pense qu'il vaut mieux ne pas se précipiter.

Le passage à Mavericks a de nombreux effets de bord !

RE: Installation d'AMC sous OS X - Added by Joël Brogniart almost 7 years ago

Bon, je viens de faire une réinstallation totale de MacPort puis une installation d'auto-multiple-choice. L'installation de deux dépendances n'ont pas fonctionné correctement (urw-fonts et dejavu-fonts). À chaque fois, il a suffit de lancer à nouveau l'installation d'auto-multiple-choice et l'installation qui a échoué se termine correctement. Un test rapide des principales fonctionnalités d'AMC s'est déroulé correctement. Donc pour l'instant, à part les petits soucis sur les dépendances, tout semble fonctionner correctement.

Installation sur MacBook Pro 15" Retina, OS X 10.9, Xcode 5.0.2, XQuartz 2.7.5, MacPorts 2.2.1.

RE: Installation d'AMC sous OS X - Added by Emmanuel Volte over 6 years ago

Bonjour,
j'ai testé l'installation sous Maverick.
Après avoir installé Xquartz, les polices libertine, macports, puis avoir lancé avec succès
sudo port
install auto-multiple-choice
exit

J'obtiens l'erreur suivante au lancer de auto-multiple-choice :
Can't locate Gtk2.pm in @INC (@INC contains: /opt/local/lib/perl5/site_perl/5.16.1/darwin-thread-multi-2level /opt/local/lib/perl5/site_perl/5.16.1 /opt/local/lib/perl5/vendor_perl/5.16.1/darwin-thread-multi-2level /opt/local/lib/perl5/vendor_perl/5.16.1 /opt/local/lib/perl5/5.16.1/darwin-thread-multi-2level /opt/local/lib/perl5/5.16.1 /opt/local/lib/perl5/site_perl /opt/local/lib/perl5/vendor_perl .) at /opt/local/lib/AMC/perl/AMC-gui.pl line 23.
BEGIN failed--compilation aborted at /opt/local/lib/AMC/perl/AMC-gui.pl line 23.

Quelqu'un peut-il m'aider ? Merci.

RE: Installation d'AMC sous OS X - Added by Emmanuel Volte over 6 years ago

Bonjour,
j'ai finalement réussi à lancer AMC en ajoutant sous MacPort les paquets suivants :
p5-gtk2
p5-xml-simple
p5.16-locale-gettext
p5-xml-writer
p5.16-archive-zip
p5.16-dbi
p5.16-text-csv

Puis j'ai du chercher le fichier automultiplechoice.sty pour l'ajouter à ma version de latex.
J'ai réussi pour l'instant à produire de multiple documents, je n'ai pas encore testé le scan !
Bon courage pour ceux qui ont un mac sous Maverick !

RE: Installation d'AMC sous OS X - Added by Joël Brogniart over 6 years ago

Bon, j'ai trouvé un moment pour faire quelques tests. MacPorts a changé la version par défaut de Perl 5 qui est maintenant la 5.16.xx et du coup certaines dépendances ne sont plus respectées. J'ai modifié la description du port pour utiliser les modules version 5.16, testé le résultat et tout fonctionne. J'essaierai de mettre à jour le port sur MacPorts la semaine prochaine.

RE: Installation d'AMC sous OS X - Added by Hervé Cabaud over 6 years ago

Pour les utilisateurs mac, je me suis fais un petit lanceur à glisser dans le dossier application ou autre pour lancer directement amc par clic sans passer par le terminal. je peux le partager s'il marche pour d'autre. L'icone n'est pas terrible en résolution mais ça marche. ( il faut bien sur que l'application soit bien installée et fonctionnelle avant ! )

AutoMultipleChoice.app.zip - lanceur amc (181.8 kB)

RE: Installation d'AMC sous OS X - Added by Hervé Cabaud over 6 years ago

hum, désolé, comment éditer le message pour corriger mes fautes ?

(1-9/9)