Installation AMC 1.2.1 sur Ubuntu 20.04

Added by Ludovic Bonivento about 1 month ago

Bonjour,

J'aimerais savoir si il est possible d'installer une ancienne version d'AMC, la 1.2.1-2, sur Ubuntu 20.04 Focal ?

Je voudrais tester le plugin Moodle d'AMC est celui-ci requiert apparemment cette ancienne version pour fonctionner.

J'ai essayer de compiler depuis les sources, mais je n'y arrive pas. J'ai des problèmes avec opencv.

Merci d'avance de votre aide
Ludovic


Replies (4)

RE: Installation AMC 1.2.1 sur Ubuntu 20.04 - Added by Alexis Bienvenüe about 1 month ago

Je pense qu'on peut utiliser les programmes AMC-detect et AMC-buildpdf de la version actuelle (donc plus de problème de compilation), avec le reste provenant de la version 1.2.1.

RE: Installation AMC 1.2.1 sur Ubuntu 20.04 - Added by Ludovic Bonivento about 1 month ago

Bonjour Alexis,

J'ai comme proposé utiliser AMC-detect et AMC-buildpdf de la version actuelle (auto-multiple-choice_1.4.0~rc2_sources.tar.gz), et modifié/ajouté quelques include afin de compiler avec les sources 1.2.1 (auto-multiple-choice_1.2.1_sources.tar.gz). Puis j'ai pu finaliser le make install sans erreurs.

J'ai par contre maintenant le message d'erreur suivant qui s'affiche lorsque je démarre AMC : The package auto-multiple-choice-common is installed, but not auto-multiple-choice. AMC won't work properly until you install auto-multiple-choice package!

Si je fais un apt-get install auto-multiple-choice il va écraser les packages de la 1.2.1 et installer la dernière version complète.

N'ai-je pas pris les bonnes sources ? voici les liens que j'ai utilisés :

Merci pour votre aide
Ludovic

RE: Installation AMC 1.2.1 sur Ubuntu 20.04 - Added by Alexis Bienvenüe about 1 month ago

The package auto-multiple-choice-common is installed, but not auto-multiple-choice. AMC won't work properly until you install auto-multiple-choice package!

Ça veut dire que AMC a vu que le paquet debian auto-multipl-choice-common est installé, mais pas auto-multiple-choice. Il fut un temps où installer AMC à partir du logiciel de gestion des applications de Ubuntu menait à cette situation, qui ne permettait pas de faire fonctionner AMC correctement, d'où l'avertissement.
Avec une installation manuelle, ce n'est sans doute pas grave, et on peut utiliser AMC quand même.

RE: Installation AMC 1.2.1 sur Ubuntu 20.04 - Added by Ludovic Bonivento about 1 month ago

Ok merci pour l'info.

C'est tout bon j'arrive à utiliser maintenant le plugin AMC moodle avec cette version d'AMC installée.

Merci pour votre aide
Ludovic

(1-4/4)