Installation AMC sur un mac M1

Added by Antoine Bluheim over 1 year ago

Bonjour,

Avant de changer mon macbook pro qui commence à se faire vieux pour un nouveau Mac M1, je voulais savoir si des personnes avaient réussi à installer AMC "facilement" sur ce genre de machine maintenant qu'elles sont dispo pour le grand public.

Merci pour vos retours!
Antoine


Replies (140)

RE: Installation AMC sur un mac M1 - Added by Maël Valais 9 months ago

Bonjour à tous,

Le correctif pour gobject-introspection est planifié pour gobject-introspection 1.7.2, qui sortira sans doute dans moins de deux mois. Dès que 1.7.2 sort, Macport et Homebrew-amc pourront fonctionner sur Apple Silicon.

Source: https://gitlab.gnome.org/GNOME/gobject-introspection/-/merge_requests/298

Maël

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 9 months ago

Ahhhh génial!! Ca c'est une super nouvelle pour Noel!
Merci encore Maël!!

RE: Installation AMC sur un mac M1 - Added by Maël Valais 8 months ago

Bonjour à tous,

J'ai mis à jour la formule Homebrew pour auto-multiple-choice pour les macs M1.

J'ai dû patcher le package perl Glib::Object::Introspection ainsi qu'utiliser une version unreleased de gobject-introspection.

Ça devrait fonctionner maintenant !

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Ahhhhhhh génial! C'est en cours d'installation! Verdict dans quelques minutes!!

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Ahhhhh, ça a pas l'air de fonctionner encore!
==> perl Makefile.PL INSTALL_BASE=/opt/homebrew/Cellar/auto-multiple-choice/1.5.
Error: An exception occurred within a child process:
Utils::Inreplace::Error: inreplace failed
Makefile:
expected replacement of "-L/usr/local/lib" with ""

antoine@Antoines-iMac ~ % auto-multiple-choice
zsh: trace trap auto-multiple-choice
antoine@Antoines-iMac ~ %

Après c'est peut-être parce que j'avais tenté de l'installer déjà avant et qu'il faudrait faire une clean Install ?

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Le problème est le même après une clean Install.
> Applying glib-gobject-introspection-0.045.diff
patching file GObjectIntrospection.xs
patching file gperl-i11n-callback.c
> perl Makefile.PL INSTALL_BASE=/opt/homebrew/Cellar/auto-multiple-choice/1.5.0/libexec INSTALLMAN1DIR=none INSTALLMAN3DIR=none
Error: An exception occurred within a child process:
Utils::Inreplace::Error: inreplace failed
Makefile:
expected replacement of "-L/usr/local/lib" with ""

antoine@iMac-de-Antoine ~ % auto-multiple-choice
zsh: command not found: auto-multiple-choice

RE: Installation AMC sur un mac M1 - Added by Maël Valais 8 months ago

C’est un bug que j’ai introduit, je vais corriger
Aussi je crois qu’il y a encore un bug avec OpenSSL et Net::SSLeay et aussi un problème avec libffi.

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Ahhh! Bon j'ai bien fait de pas revendre mon MacBook Pro intel la semaine dernière! :D

RE: Installation AMC sur un mac M1 - Added by Maël Valais 8 months ago

Ça y est ça marche !

RE: Installation AMC sur un mac M1 - Added by Valérian M. 8 months ago

Bonsoir,

Tout d'abord merci beaucoup d'adapter la formule homebrew au M1.
J'ai relancé l'installation de la recette avec la commande :

"brew install maelvls/amc/auto-multiple-choice"

Quand j'ai lancé AMC avec la commande "auto-multiple-choice" j'ai eu un message d'erreur me parlant d'une commande latex en me disant que peut-être LaTeX n'est pas installé.
Du coup je suis allé ici : https://tug.org/mactex/morepackages.html et j'ai installé la version minimale BasicTeX.pkg
Et maintenant quand je lance AMC, ça me dit "Le fichier style automultiplechoice.sty ne semble pas être accessible par LaTeX. Essayer la commande 'auto-multiple-choice latex-link' en tant que super utilisateur (root) pour corriger ce problème.

Je lance la commande demandée 'auto-multiple-choice latex-link'
et j'obtiens encore un message d'erreur 'ERROR: I don't find the command texconfig-sys. Perhaps LaTeX is not installed?'
Je suis désolé si c'est une broutille pour vous mais je commence à désespérer. Pouvez-vous m'aider?

RE: Installation AMC sur un mac M1 - Added by Valérian M. 8 months ago

Bon, désolé de m'étaler, mais, en installant la version complète de mactex ici https://tug.org/mactex/mactex-download.html
ça règle ce problème.

Maintenant en compilant un fichier dans AMC j'ai un autre message d'erreur :-(
Il me dit que les polices libertines ne sont pas installées.

je suis allé les chercher ici https://sourceforge.net/projects/linuxlibertine/

Et j'ai copié les fichiers otf ici : MacintoshHD/Library/Fonts

j'ai toujours l'erreur :-(

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Je teste dans la matinée et je vous dit! Il faut relancer l'installation de zéro tu penses?

RE: Installation AMC sur un mac M1 - Added by Maël Valais 8 months ago

Ah mince, je n'ai pas pensé à tester si mactex et auto-multiple-choice latex-link fonctionnent bien. J'y jetterai un coup d'oeil

Pas besoin d'installer "de zéro" je pense

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

J'ai du faire un auto-multiple-choice latex-link sinon ça mettait un message d'alerte au lancement.
AMC se lance, j'ai essayé de charger un projet existant mais une fenêtre d'erreur s'est lancée. J'ai pas pu regarder plus en détail, je jette un oeil plus tard dans la journée.

RE: Installation AMC sur un mac M1 - Added by Maël Valais 8 months ago

@Valérian: peux-tu ouvrir une issue sur GitHub avec un screenshot? https://github.com/maelvls/homebrew-amc/issues/new

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Voilà l'erreur à la compilation. Une idée? J'ai jamais eu ça!

RE: Installation AMC sur un mac M1 - Added by Maël Valais 8 months ago

Peux tu essayer

sudo auto-multiple-choice latex-link remove
sudo auto-multiple-choice latex-link

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Même problème!
Le stp vient d'ici
https://gitlab.lrde.epita.fr/lrde/share/blob/b6ce930b8343a6b9d26aeb1a257a21f838258abd/styles/automultiplechoice.sty

RE: Installation AMC sur un mac M1 - Added by Valérian M. 8 months ago

@Maël: L'issue est ouverte sur Github, j'ai mis le screenshot.

https://github.com/maelvls/homebrew-amc/issues/73

RE: Installation AMC sur un mac M1 - Added by Muriel Vander Donckt 8 months ago

Ouiiii ! Moi aussi ! Ça fonctionne ! Mille mercis Maël !! Juste à temps pour mes examens de TP !

RE: Installation AMC sur un mac M1 - Added by Antoine Bluheim 8 months ago

Muriel, tu utilises quelle version du fichier sty? J'ai peut-être pas pris la bonne!

RE: Installation AMC sur un mac M1 - Added by Valérian M. 8 months ago

Mon problème est résolu. Merci beaucoup à Maël pour son aide.
Si vous avez le même soucis que moi installez la police Linux Libertine avec homebrew en utilisant la commande brew install homebrew/cask-fonts/font-linux-libertine
et ça devrait résoudre votre problème!

RE: Installation AMC sur un mac M1 - Added by Denis Petrequin 8 months ago

Ca y est ! AMC fonctionne sur mon Mac M1. Un grand merci à toi Maël.

RE: Installation AMC sur un mac M1 - Added by Alexis Bienvenüe 8 months ago

Le sty vient d'ici
https://gitlab.lrde.epita.fr/lrde/share/blob/b6ce930b8343a6b9d26aeb1a257a21f838258abd/styles/automultiplechoice.sty

Vous ne devriez pas utiliser un fichier sty modifié, mais bien celui livré avec la version d'AMC que vous utilisez, sauf si vous savez exactement ce que vous faites ;)

RE: Installation AMC sur un mac M1 - Added by Florian Mathieu 8 months ago

Bonsoir,

J'ai le même problème, après avoir installé AMC sur mon M1 ce matin : mon éditeur latex s'est mis à jour et depuis, quand j'essaie de mettre à jour un document, j'ai une erreur m'annonçant que ma version de fichier de style n'est pas bonne.

Savez vous s'il est possible de récupérer le fichier de style sans avoir à tout réinstaller?

Merci

« Previous 1 2 3 4 5 6 Next » (76-100/140)