installation sous OpenSuse

Added by nathalie bonnin 7 months ago

Bonjour
J'ai entrepris d'installer AMC 1.4.0 sous Opensuse Leap 15.2.

Dans un premier temps j'ai voulu compiler un rpm mais l'opération échoue suite à une erreur :

pdfformfields.c:128:57: error: invalid conversion from 'gpointer {aka void*}' to 'PopplerFormFieldMapping* {aka _PopplerFormFieldMapping*}' [-fpermissive]
PopplerFormFieldMapping *f = g_list_nth_data(list, i);

J'ai donc tenté make install à partir des sources précompilées. L'installation semble se dérouler correctement mais l'applicaton ne se lance pas.
En ligne de commande j'obtiens le message suivant :

> auto-multiple-choice
Can't locate AMC/Path.pm in @INC (you may need to install the AMC::Path module) (@INC contains: /usr/lib/perl5/site_perl/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.26.1 /usr/lib/perl5/vendor_perl/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.26.1 /usr/lib/perl5/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/5.26.1 /usr/lib/perl5/site_perl) at /usr/lib/AMC/perl/AMC-gui.pl line 49.
BEGIN failed--compilation aborted at /usr/lib/AMC/perl/AMC-gui.pl line 49.

Après avoir passé pas mal de temps à faire la chasse aux paquets, j'avais l'impression d'être près du but, mais sur ces deux messages d'erreur je suis au bout de mes ressources.

Merci d'avance pour tout éclaircissement


Replies (7)

RE: installation sous OpenSuse - Added by nathalie bonnin 7 months ago

Problème de création de RPM résolu et RPM finalement installé (petit problème avec poppler qui n'existe plus en tant que paquet, mais j'ai tous les sous-paquets correspondants), AMC se lance enfin. Mais lorsque je veux générer mes fichiers ("Mettre à jour les documents'') j'obtiens ceci :

This is XeTeX, Version 3.14159265-2.6-0.99998 (TeX Live 2017/TeX Live for SUSE Linux) (preloaded format=xelatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2017-04-15>
Babel <3.10> and hyphenation patterns for 50 language(s) loaded.
(./DOC-filtered.tex (/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/xltxtra/xltxtra.sty
(/usr/share/texmf/tex/generic/oberdiek/ifluatex.sty)
(/usr/share/texmf/tex/generic/ifxetex/ifxetex.sty)
(/usr/share/texmf/tex/latex/fontspec/fontspec.sty
(/usr/share/texmf/tex/latex/l3kernel/expl3.sty
(/usr/share/texmf/tex/latex/l3kernel/expl3-code.tex)
(/usr/share/texmf/tex/latex/l3kernel/l3xdvipdfmx.def))
(/usr/share/texmf/tex/latex/l3packages/xparse/xparse.sty)
(/usr/share/texmf/tex/latex/fontspec/fontspec-xetex.sty
(/usr/share/texmf/tex/latex/base/fontenc.sty
(/usr/share/texmf/tex/latex/base/tuenc.def))
(/usr/share/texmf/tex/latex/fontspec/fontspec.cfg)))
(/usr/share/texmf/tex/latex/realscripts/realscripts.sty)
(/usr/share/texmf/tex/latex/metalogo/metalogo.sty
(/usr/share/texmf/tex/latex/graphics/graphicx.sty
(/usr/share/texmf/tex/latex/graphics/keyval.sty)
(/usr/share/texmf/tex/latex/graphics/graphics.sty
(/usr/share/texmf/tex/latex/graphics/trig.sty)
(/usr/share/texmf/tex/latex/graphics-cfg/graphics.cfg)
(/usr/share/texmf/tex/latex/graphics-def/xetex.def)))))
(/usr/share/texmf/tex/latex/AMC/automultiplechoice.sty
AMC version: 2018/12/29 v1.4.0 r:c6041a1
(/usr/share/texmf/tex/latex/xcolor/xcolor.sty
(/usr/share/texmf/tex/latex/graphics-cfg/color.cfg))
(/usr/share/texmf/tex/latex/fancyhdr/fancyhdr.sty)
! LaTeX Error: File `bophook.sty' not found.
Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)
Enter file name: 
! Emergency stop.
<read *> 

l.34 \RequirePackage
                    {xkeyval} % \setkeys^^M
No pages of output.
Transcript written on amc-compiled.log.
Unable to open amc-compiled.amc: No such file or directory at /usr/lib/AMC/perl/AMC-prepare.pl line 326.

RE: installation sous OpenSuse - Added by nathalie bonnin 6 months ago

Le problème semble résolu (il manquait encore un paquet)

RE: installation sous OpenSuse - Added by florent giordano 5 months ago

Bonjour,

Navré de m'incruster dans cette discussion un peu tardivement, mais je suis intéressé par votre procédure pour installer AMC sur OpenSuse 15.2.

Concrètement, je lance rpmbuid -tb auto-multiple-choice_1.4.0_precomp.tar.gz
et j'obtiens le message d'erreur suivant :

erreur : Dépendances de construction manquantes:
texlive-bin-latex est nécessaire pour auto-multiple-choice-1.4.0-1.x86_64

Pourtant texlive est installé sur ma machine (mais le paquet semble s'appeler texlive-bin-bin)

Comment avez-vous franchi cette étape ?

Merci de vos lumières !

RE: installation sous OpenSuse - Added by nathalie bonnin 5 months ago

Bonjour
Effectivement ce n'est plus texlive-bin-latex mais texlive-latex-bin et texlive-latex-bin-bin qui sont nécessaires. Il faut donc modifier le fichier auto-multiple-choice.spec fournit dans l'archive, en remplaçant "texlive-bin-latex" en "texlive-latex-bin-bin" aux lignes 92 et 93.
En ce qui me concerne cela n'a été que le début des problèmes à résoudre (mais je partais d'une installation minimaliste de Suse), cependant je suis contente d'avoir persisté car maintenant AMC tourne très bien. J'ai gardé quelques notes sur les problèmes croisés, si jamais...
Bon courage

RE: installation sous OpenSuse - Added by florent giordano 5 months ago

Bonsoir,

Merci de votre réponse rapide, j'ai modifié le fichier comme suggéré, puis je suis tombé sur l'erreur du début de fil

pdfformfields.c:128:57: error: invalid conversion from 'gpointer {aka void*}' to 'PopplerFormFieldMapping* {aka _PopplerFormFieldMapping*}' [-fpermissive]
PopplerFormFieldMapping *f = g_list_nth_data(list, i);

J'ai tenté de la résoudre en suivant les instructions de ce fil https://project.auto-multiple-choice.net/boards/3/topics/9185?r=9280#message-9280

Je n'ai pas eu de message d'erreur spécifique en dehors de « fichiers listés deux fois » ou de « fichiers installés, mais non empaquetés » et un exécutable (avec d'autres fichiers) a bien été généré dans le dossier rpmbuild créé pour l'occasion dans ~ (mais pas de *.rpm pour autant).

Quand je tente de l'exécuter, j'obtiens Unknown action gui at /home/utilisateur/rpmbuild/BUILD/auto-multiple-choice-1.4.0/auto-multiple-choice line 79.

Est-ce que cela vous est également arrivé ?

RE: installation sous OpenSuse - Added by nathalie bonnin 4 months ago

Bonsoir
J'ai effectivement également modifé pdfformfield.c en suivant les indications du fil que vous citez. Je me demande cependant s'il ne serait pas également judicieux de remplacer le terme 'poppler' à la ligne 91 de auto-multiple-choice.spec par "libpoppler" (je ne l'ai pas fait mais ai buté ultérieurement sur le problème)
Le problème des "fichiers installés mais non empaquetés" se résout en ajoutant la liste des fichiers en question à la fin de la section "Files" de auto-multiple-choice.spec.
Une fois ceci fait j'obtiens bien un rpm en fin de procédure, que j'ai installé avec Yast.

RE: installation sous OpenSuse - Added by florent giordano 4 months ago

Bonjour,

Merci pour ces conseils, il y avait bien un problème avec poppler, mais je l'ai résolu supprimant la référence à poppler dans le fichier auto-multiple-choice.spec (mais en gardant poppler-tools sur la même ligne), car ajouter libpoppler a conduit à un problème lors de l'installation du RPM via Yast (libpoppler n'existant pas en version >= 0.12.3 dans les dépôts d'OpenSuse, peut-être faudrait-il à la place indiquer libpoppler89 en modifiant la bibliothèque minimale requise à 0.79 ou python-poppler (sans modifier la numérotation)). En même temps, j'avais toutes les dépendances à Poppler installées (gérées lors de l'installation de pdfshuffler sur mon système), donc je ne me suis pas attardé sur la question.

Je documente pour la postérité deux-trois étapes complémentaires qu'il a fallu franchir :

  • quand le logiciel ne se lance pas pour cause de => Unknown action gui at auto-multiple-choice line 79, se reporter à ce fil => https://project.auto-multiple-choice.net/boards/2/topics/9523
  • dépendance supplémentaire à installer => perl-Gtk3 (absent des dépôts, se reporter à https://software.opensuse.org/package/perl-Gtk3, j'ai pris le paquet expérimental pour 15.2, devel:languages:perl Expérimental)
  • dépendance supplémentaire à installer => perl-clone (accessible dans les paquets, nécessaire pour la génération de PDF via LaTeX)

Bien à vous

(1-7/7)