student.id allways 0

Added by Florian Schoengassner about 1 month ago

Hi!
We recently upgraded to AMC 1.4. Some projects weren't finished before the upgrade and now we are facing a problem with the detection of our student identifiers. Layout seems to be perfectly detected, but student.id is always 00000000 after detection.
Any ideas?


Replies (6)

RE: student.id allways 0 - Added by Alexis Bienvenüe about 1 month ago

Can you run the following command from a terminal in the project directory, and report the output?

sqlite3 data/layout.sqlite 'select value from layout_variables where name="build:codedigit"'

RE: student.id allways 0 - Added by Alexis Bienvenüe about 1 month ago

Some projects weren't finished before the upgrade

Which steps did you perform with the previous version, and which with 1.4.0?
Did you extract the scoring strategy (box to tick before requesting to compute the marks) with 1.4.0?
Are the marks OK?
Can you try the following command, replacing codename with the name of the student code used in \AMCcode?

sqlite3 data/scoring.sqlite 'select * from scoring_title where title like "codename%"'

RE: student.id always 0 - Added by Florian Schoengassner about 1 month ago

Alexis Bienvenüe wrote:

Some projects weren't finished before the upgrade

Which steps did you perform with the previous version, and which with 1.4.0?

we prepared everything with 1.2.1, then the exams were written and finally I upgraded our server not noticing that there was still an unfinished project.

Did you extract the scoring strategy (box to tick before requesting to compute the marks) with 1.4.0?

Yes.

Are the marks OK?

Yes, everything else seems to be fine.

Can you try the following command, replacing codename with the name of the student code used in AMCcode?

sqlite3 data/scoring.sqlite 'select * from scoring_title where title like "codename%"'

1|student.number[8]
2|student.number[7]
3|student.number[6]
4|student.number[5]
5|student.number[4]
6|student.number[3]
7|student.number[2]
8|student.number[1]

Just to clarify, we are using AMC-TXT.

RE: student.id allways 0 - Added by Alexis Bienvenüe about 1 month ago

Can you extract the scoring strategy and compute the marks again in debugging mode, and post the corresponding log file?

RE: student.id allways 0 - Added by Joël Brogniart about 1 month ago

I got the same problem with two AMC installations (issue #620). When scanning subjects in AMC 1.4 with projects created with a previous version of AMC, I had student numbers set to 0.

After many tests and tries, I found a solution to have student numbers back.

First duplicate the project folder. Then, in the "Preparing" tagb, press the "Update documents", the "Layout detection" button. After that you have to import scans again and so on.

(1-6/6)