Problem running on Windows subsystem for Linux

Added by Giovanni Giuffrida over 4 years ago

Hi there, I'm trying to run AMC on the new Ubuntu Linux subsystem for windows (https://msdn.microsoft.com/en-us/commandline/wsl/about). This is a Ubuntu linux integrated with Windows, so you don't need to run a full virtual machine on your PC. I have been using it for quite a bit and everything works well and I think it would be great to run AMC directly from a Windows-bash shell.

I can install AMC trough the normal "apt-get install" and everything runs properly up, I can create all exams in pdf with no problem whatsoever. Up to when I capture the pdf scan of the answer sheets as I get an Sqlite error:

SQL ERROR: DBD::SQLite::db do failed: disk I/O error
SQL STATEMENT: COMMIT
SQL ERROR: DBD::SQLite::db do failed: disk I/O error
SQL STATEMENT: COMMIT

In my opinion, for some reasons, sqlite was not properly initialized by AMC. I can run Sqlite with no problem from the shell, so it's not a problem per se.

Anyone can help? Thanks a lot for the incredibly useful work!!!!


Replies (9)

RE: Problem running on Windows subsystem for Linux - Added by Alexis Bienvenüe over 4 years ago

Can you provide a log file produced by AMC in debugging mode (from the Help menu)?

RE: Problem running on Windows subsystem for Linux - Added by Alexis Bienvenüe over 4 years ago

Can it be some disk space problem?
Can you try the following command in the linux terminal?

df -h

RE: Problem running on Windows subsystem for Linux - Added by Giovanni Giuffrida over 4 years ago

No, it's not a disk related issue... this is the output:

Filesystem Size Used Avail Use% Mounted on
rootfs 476G 157G 319G 33% /
data 476G 157G 319G 33% /data
cache 476G 157G 319G 33% /cache
mnt 476G 157G 319G 33% /mnt
none 476G 157G 319G 33% /dev
none 476G 157G 319G 33% /run
none 476G 157G 319G 33% /run/lock
none 476G 157G 319G 33% /run/shm
none 476G 157G 319G 33% /run/user
C: 476G 157G 319G 33% /mnt/c
root 476G 157G 319G 33% /root
home 476G 157G 319G 33% /home

RE: Problem running on Windows subsystem for Linux - Added by Alexis Bienvenüe over 4 years ago

What is your Ubuntu version? Can you install the AMC development version from the PPA to see if something is different?

RE: Problem running on Windows subsystem for Linux - Added by Giovanni Giuffrida over 4 years ago

This is the version:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial

How can I install the AMC development version?

RE: Problem running on Windows subsystem for Linux - Added by Alexis Bienvenüe over 4 years ago

How can I install the AMC development version?

See the PPA page.

RE: Problem running on Windows subsystem for Linux - Added by Giovanni Giuffrida over 4 years ago

Thanks Alexis, sorry for the question again, how does it work? Do I need to add those lines and then reinstall auto-multiple-choice with the usual "apt-get install..."??

Sorry, I'm not familiar with that process

Thanks for your help

Giovanni

RE: Problem running on Windows subsystem for Linux - Added by Alexis Bienvenüe over 4 years ago

Commands to type in the terminal:

sudo add-apt-repository ppa:alexis.bienvenue/test
sudo apt-get update
sudo apt-get install auto-multiple-choice

(1-9/9)