Problem with marks and reports

Added by Roberto Zanasi about 6 years ago

Hello, I'm trying AMC for the first time and, before using it with my students, I would like to try it in order to understand how it works. So, I tried some example files, and I simulated an exam. Everything works fine until I have to computer marks: I click on the "Mark" button, then on the "Look at marks" one, a window appears with the calculated marks, but the main windows says "No marks computed". So all the options in the report label are grey and not selectable.

What am I doing wrong?

Thanks.


Replies (4)

RE: Problem with marks and reports - Added by Alexis Bienvenüe about 6 years ago

Please mark again with debugging enabled (from the Help menu), and post the produced log file.

RE: Problem with marks and reports - Added by Roberto Zanasi about 6 years ago

Ehm, sorry to seem such a newbie, but after a restart everything works fine. I will try another example file, and if the error shows up again, I will post the log file. Thanks

RE: Problem with marks and reports - Added by Roberto Zanasi about 6 years ago

Ok, I have tried with another example. First run, without debugging enabled, same problem. The command line window says:

Use of the encoding pragma is deprecated at /usr/lib/AMC/perl/AMC-prepare.pl line 21.
Use of the encoding pragma is deprecated at /usr/lib/AMC/perl/AMC-note.pl line 28.
  • unhandled exception in callback:
  • GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files at /usr/lib/AMC/perl/AMC-gui.pl line 443.
  • ignoring at /usr/lib/AMC/perl/AMC-gui.pl line 7093.
    Argument "" isn't numeric in numeric eq (==) at /usr/share/perl5/AMC/Gui/Notes.pm line 118.

I have enabled debug and recalculated marks, I will attach the log file.

After closing and reopening auto-multiple-choiche, the problem is gone and I have a green light on "Mean".

That's all.

RE: Problem with marks and reports - Added by Alexis Bienvenüe about 6 years ago

The name org.freedesktop.Notifications was not provided by any .service files

Try to untick Edit/Preferences/Display/Notifications/Desktop notifications.

(1-4/4)