Test version, AM-TXT bold and italic options do not work

Added by Nikola Z. Guscic over 7 years ago

When the question compiles I see no discernible difference in the between normal and 'bold' text.
I've tried using LaTex options \emph{} and \textbf{} and also see no difference. The test version has been updated last night.

**[columns=3,ordered,indicative,question=First Choice,name=First Choice]{mz=0,auto=1} [*FIRST CHOICE*]
If you chose Coordinated Science option you may select \emph{three} additional subjects as a first choice. 
If you chose Specialized Sciences option you may select \emph{two} additional subjects as a first choice. 

- Geography
- History
+ Travel and Tourism
- Economy
- Business Studies

AMCtextDYtemplate.tex - Minimal example (3.1 kB)


Replies (2)

RE: Test version, AM-TXT bold and italic options do not work - Added by Alexis Bienvenüe over 7 years ago

It comes from the #293 bugfix, which selects only one variant of the font, leading to ineffective \textit and \textbf calls.
Try using the old version, with:

Font: Linux Libertine O

It seems that we have to find a better fix for #293!

RE: Test version, AM-TXT bold and italic options do not work - Added by Nikola Z. Guscic over 7 years ago

Thank you for your reply.

Using the test version, as a quick fix I renamed DOC-filtered.tex to source.tex and switched the project to LaTex instead of AMC-TXT mode. I chose xelatex as a LaTex engine under Edit/Preferences/Project. I added two lines to the document preamble:


\usepackage{biolinum}
\usepackage[T1]{fontenc}


Now italics, bold and emphasis render properly again. One could also use LibertineMono instead of biolinum but with LibertineRoman, bold and italics don't work. If I add the same code to LaTex-Preamble in the original AMC-TXT file, it doesn't make a difference.

(1-2/2)