No Layout for ID +0/0/0+ error during automatic capture

Added by Steve Murphy 7 months ago

Hello,

Firstly, thank-you for developing such a useful piece of software. I've been using it for many years and it's a joy to use.

However, I get the I'm getting the above message repeatedly for scans based on a paper I recently built and tested. During testing of the exam with sample scans, the system worked fine, so I'm puzzled as to why it's now not working for the real exams. I can see others have had this issue, but a very long time ago and I'm not sure the solutions are applicable.

I am using the latest version of the software (1.5.2) from the PPA and am running on Ubuntu 20.04. I have tried toggling the force conversion on and off, this has no apparent impact. The error says look at the image files and they seem to be fine with no obvious issues or corruption.

Attaching log seems to lead an error posting, but happy to send via another channel.

Thanks in advance.

Steve


Replies (10)

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Alexis Bienvenüe 7 months ago

Can you open the unrecognized scans window (Click Look at scans next to xx cans were not recognized), select a problematic scan, click on Pre-process, and post a screenshot with the scan and the pre-processed version side by side?

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Steve Murphy 7 months ago

Hi Alexis,

File attached. Name etc. redacted.

Thanks.

Steve

AMCPreprocessed.jpg (137.4 kB)

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Alexis Bienvenüe 7 months ago

Thanks. We can see that the boxes that allows AMC to detect the student and page (here +1/1/60+) are not where they are supposed to be (the colored squares show where AMC thinks they should be):

  • Maybe the printed sheets are not exactly the same as the subject sheets in the project directory (this can happen when one rebuilds the documents after printing the sheets).
  • Maybe the scanner distorted the image significantly, with eg. a non-constant speed along the short-side axis.

id.png (22.1 kB)

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Steve Murphy 7 months ago

Hi Alexis,

Thanks for the speedy reply. I'm not sure how this has happened, as the project has not been rebuilt, and they are using the correct sheet. I can only assume there is some odd rescaling going on when they are printing/scanning the sheets. When I print the scanned, completed sheets at my end, they occupy noticeably less of the paper than a standard blank PDF answer paper I print direct from AMC. Are there any options I can tweak in the system to cope with this?

Thanks again.

Regards.

Steve

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Alexis Bienvenüe 7 months ago

I can only assume there is some odd rescaling going on when they are printing/scanning the sheets

Can you try again to scan one page? If the problem comes from the scanning step, maybe it'll work the second time…
Can you also post the extracted 1/1/60 page from DOC-sujet.pdf?

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Rafael Rodriguez 7 months ago

We printed once using acrobat reader with the "adjust large pages" option on.
It reduced the size of the printed portion.

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Steve Murphy 7 months ago

Hi Alexis and Rafael

Rafael: I have spoken to those who printed and scanned the sheet, as I did note that printing it from a browser preview seemed to make it smaller than when printed from a traditional PDF viewer. However, they claim to have printed it via Adobe Acrobat and say they did not scale it.

Alexis: I asked them to scan some sample pages using the flatbed and feeder, and also take some pictures with their phone. When I run them through AMC it seems some of them are recognised, but not others. For a larger sample, around 20% were recognised, the rest were rejected with the same error as above. Neither flatbed nor scanner seemed to be more reliable.

DOC-Sujet attached.

Thanks again.

Regards.

Steve

DOC-sujet.pdf (36.9 kB)

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Alexis Bienvenüe 7 months ago

DOC-Sujet attached.

Thanks. Placing DOC-sujet (in red) on top of the scan with circles at the same position, one can see differences that lead to AMC errors. I can't say where these differences come from…

RE: No Layout for ID +0/0/0+ error during automatic capture - Added by Alexis Bienvenüe 7 months ago

Also compare these spaces differences.

AMCPreprocessed.jpg (20.4 kB)

DOC-sujet2.jpg (16.6 kB)

(1-10/10)