Some symbols are not available when using pdflatex

Added by Nhu Le almost 9 years ago

I have been trying to output some vietnamese text but I have an error saying

Package inputenc Error: Unicode char \u8:­ not set up for use with LaTeX.

This turned out to be a space that is not supported. If I remove the space and put my own space then it would be ok. Since I am using the cvssimple package to generate my files, I would like to either fix it or automate the process.

I have tried several things: using utf8x package, using textcomp package. But I have the same problem.

Do you have any suggestion?

Thank you.


Replies (6)

RE: Some symbols are not available when using pdflatex - Added by Alexis Bienvenüe almost 9 years ago

It is very hard to help you without a minimal file showing your problem...

RE: Some symbols are not available when using pdflatex - Added by Nhu Le almost 9 years ago

I am sorry. Attached is the simple pdf file I used to test the program.

It looks like the byte "A0" and "CC" may be the problem. I can probably remove them from the file but I would like to know the real problem and a good way to fix it.

unicode_input.txt (65 Bytes)

RE: Some symbols are not available when using pdflatex - Added by Alexis Bienvenüe almost 9 years ago

Can you also send the source LaTeX file so that we can reproduce the problem easily?

RE: Some symbols are not available when using pdflatex - Added by Nhu Le almost 9 years ago

I trimmed the .tex file to get a minimal case

dhcd.person.csv (77 Bytes)

input.tex (1 kB)

RE: Some symbols are not available when using pdflatex - Added by Nhu Le almost 9 years ago

I think the problem is that my configuration does not support Unicode Composite. It does support Unicode correctly.

If I use a converter to convert the input file from Unicode Composite (which is a legacy unicode???) to Unicode then it would work. One such converter can be found on sourceforge.

If we can find a way to support this, I would be very happy but at least there is one workaround for this problem.

Nhu

RE: Some symbols are not available when using pdflatex - Added by Alexis Bienvenüe almost 9 years ago

Thanks. It seems that xelatex can handle this kind of encoding properly. Try to replace

\usepackage[utf8]{inputenc}    
\usepackage[T5]{fontenc}

with
\usepackage{xltxtra}

and use xelatex instead of pdflatex as the LaTeX engine (when compiling separately, and/or in Edit/Preferences/Project/External commands/LaTeX engine).

(1-6/6)