AMC not running after Homebrew installation on Mac

Added by Matthew Huber 4 months ago

I installed AMC from homebrew, then installed mactex. When I tried to run it, I got the following error message:

Typelib file for namespace 'Pango', version '1.0' not found at /usr/local/Cellar/auto-multiple-choice-devel/1.4.0_1/libexec/lib/perl5/darwin-thread-multi-2level/Glib/Object/Introspection.pm line 108.
BEGIN failed--compilation aborted at /usr/local/Cellar/auto-multiple-choice-devel/1.4.0_1/lib/AMC/perl/AMC-gui.pl line 23.

I uninstalled, then installed the devel version. There was no difference. What do I need to do?


Replies (11)

RE: AMC not running after Homebrew installation on Mac - Added by Maël Valais 4 months ago

Hi!

I am trying to reproduce right now; I updated the bottles yesterday night in order to fix the opencv4 issue and now there apparently is a new bug 🙄

RE: AMC not running after Homebrew installation on Mac - Added by Maël Valais 4 months ago

I cannot reproduce 😕

Which buttons in the UI did you click in order to get this message?
Did you get it immediately after launching auto-multiple-choice?
Which version of macOS are you running?

RE: AMC not running after Homebrew installation on Mac - Added by Matthew Huber 4 months ago

Maël Valais wrote:

I cannot reproduce 😕

Which buttons in the UI did you click in order to get this message? Did you get it immediately after launching auto-multiple-choice?

I did not get to the UI. I installed, then typed in the terminal auto-multiple-choice, then I get the above messages.

RE: AMC not running after Homebrew installation on Mac - Added by Maël Valais 4 months ago

I am lost, I cannot find the possible source for this issue 😰

Let's try reinstalling an older version of amc. Let's try with auto-multiple-choice-devel-1.4.0-rc2:

brew unlink auto-multiple-choice auto-multiple-choice-devel
brew install https://raw.githubusercontent.com/maelvalais/homebrew-amc/b58dbb0c543404e4d9332d9d09b443cab894fc8c/auto-multiple-choice-devel.rb

Can you tell me if you still get the message? If the error disappears, there might be something wrong with my new 1.4.0_1 bottles 🤗 If the error is still here, wow, I am really stuck

update: wait, I don't think using a previously built version is a good idea as you may not have the required dynamic libs installed... I'm really out of imagination.

Out of curiosity, what is the output of brew config?

RE: AMC not running after Homebrew installation on Mac - Added by Matthew Huber 4 months ago

I will give it a try as soon as possible, but it will probably only be in a couple of hours. Will post here when I have attempted.

RE: AMC not running after Homebrew installation on Mac - Added by Matthew Huber 4 months ago

Matthews-MBP:~ matthewhuber1$ brew config
HOMEBREW_VERSION: 1.8.6
ORIGIN: https://github.com/Homebrew/brew
HEAD: 858c5e1afb0eb00079a4f014e8fbedf9065d50e4
Last commit: 3 weeks ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: 06a5fe17614d3e5426858ba46591ec9ea0e61577
Core tap last commit: 13 hours ago
HOMEBREW_PREFIX: /usr/local
CPU: quad-core 64-bit sandybridge
Homebrew Ruby: 2.3.7 => /usr/local/Homebrew/Library/Homebrew/vendor/portable-ruby/2.3.7/bin/ruby
Clang: 9.1 build 902
Git: 2.15.2 => /Applications/Xcode.app/Contents/Developer/usr/bin/git
Curl: 7.54.0 => /usr/bin/curl
Java: 1.6.0_65-b14-468
macOS: 10.13.4-x86_64
CLT: 10.1.0.0.1.1539992718
Xcode: 9.4.1
XQuartz: 2.7.11 => /opt/X11

RE: AMC not running after Homebrew installation on Mac - Added by Matthew Huber 4 months ago

Installed the old version, got the same message:

Matthews-MBP:~ matthewhuber1$ auto-multiple-choice
Typelib file for namespace 'Pango', version '1.0' not found at /usr/local/Cellar/auto-multiple-choice-devel/1.4.0-rc2/libexec/lib/perl5/darwin-thread-multi-2level/Glib/Object/Introspection.pm line 108.
BEGIN failed--compilation aborted at /usr/local/Cellar/auto-multiple-choice-devel/1.4.0-rc2/lib/AMC/perl/AMC-gui.pl line 23.

RE: AMC not running after Homebrew installation on Mac - Added by Alexis Bienvenüe 4 months ago

Can you try to uninstall and install again pango with homebrew?

RE: AMC not running after Homebrew installation on Mac - Added by Maël Valais 4 months ago

I cannot find an explanation for this issue ☹️

I'll try again tomorrow

RE: AMC not running after Homebrew installation on Mac - Added by Matthew Huber 4 months ago

I uninstalled Pango, then reinstalled. AMC didn't work. I uninstalled it, reinstalled it, and got the same (new) error:

Matthews-MBP:~ matthewhuber1$ auto-multiple-choice

(process:53937): GLib-CRITICAL **: gpointer g_hash_table_lookup(GHashTable *, gconstpointer): assertion `hash_table != NULL' failed

(process:53937): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()

(process:53937): GLib-CRITICAL **: void g_once_init_leave(volatile void *, gsize): assertion `result != 0' failed

After this message appeared, the process ran for several minutes and nothing happened.

RE: AMC not running after Homebrew installation on Mac - Added by Maël Valais 4 months ago

oww, it is getting weirder and weirder

Out of luck, could you try reinstalling all AMC dependencies? Here is the command:

brew deps auto-multiple-choice | xargs brew reinstall

(1-11/11)