Installation using MacPorts on OSX 10.11.6 fails

Added by Catherine Peterson 8 months ago

I've installed MacPorts, XCode 8.2, and the fonts Linux Libertine & Dejavu. However, when I go to type in "sudo port install auto-multiple-choice", get the following error code:

--->  Computing dependencies for auto-multiple-choice
--->  Building auto-multiple-choice
Error: Failed to build auto-multiple-choice: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port auto-multiple-choice failed

Can anyone tell me what I still need to get to make it work?

Catherine


Replies (7)

RE: Installation using MacPorts on OSX 10.11.6 fails - Added by Joël Brogniart 8 months ago

Could you please attach the log file?

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/main.log

RE: Installation using MacPorts on OSX 10.11.6 fails - Added by Joël Brogniart 8 months ago

Did you install the fonts with the Font Book application? It seems that the application install the fonts in the user space by default. To be used by TeX tools the font should be in the Computer space (for all users). Could you use the Font Book application to move the DejaVu, LinuxLibertine, IPAexMincho and IPAexGothic to the Computer space?

RE: Installation using MacPorts on OSX 10.11.6 fails - Added by Catherine Peterson 8 months ago

I moved the DejaVu and LinuxLibertine fonts, and downloaded the two IPA fonts (which I didn't have). However, I still get the same error message. I've attached the new log.

main.log.zip (86.7 kB)

RE: Installation using MacPorts on OSX 10.11.6 fails - Added by Catherine Peterson 8 months ago

Could I actually get a list of all of the apps and other things that I need to have installed on my Mac (OSX El Capitan), to have AMC run through MacPorts? I get the feeling that I'm still missing at least one, but I can't find a convenient list anywhere.

RE: Installation using MacPorts on OSX 10.11.6 fails - Added by Joël Brogniart 8 months ago

You could find installation instructions at Installing AMC on macOS.

Your log show that you have to accept Xcode licence.

:error:main It seems you have not accepted the Xcode license; most ports will fail to build.

You should run Xcode and validate the licence agreement that will appear. If Xcode tell you to install complementary tools, accept the installation. But I don't think that this will solve the font problem.

RE: Installation using MacPorts on OSX 10.11.6 fails - Added by Catherine Peterson 8 months ago

I had to go in through Terminal to accept the license, because it wasn't showing up when I opened projects in XCode. With that done, I went through and re-read the Mac-relevant section. I had done everything else there, so the fonts must not be installed correctly because that's the only thing you all seem to be picking up. The four font families are located in HD/Library/Fonts (I see 9 DejaVu fonts, 2 IpA fonts, and 16 LinLibertine fonts). I used FontBook to check, and all fonts are under "All Fonts", but the Linux Libertine Initials font claims to have a duplicate somewhere, though none of the searches I've tried can find it. I've tried removing all of the LinuxLibertine fonts and re-installing them, but the duplicate flag is still there. Would that duplicate flag be causing the problem?

(1-7/7)