Problems with Mac installation

Added by Marco Muzi Falconi 11 months ago

I have installed AMC using homebrew.
I then typed "sudo auto-multiple-choice latex-link" in the Terminal, as per instructions, but I get back an error:
"ERROR: I don't find the command kpsewhich. Perhaps LaTeX is not installed?"
But mactex was successfully installed.

Anybody can help me?

thanks
marco


Replies (6)

RE: Problems with Mac installation - Added by Marco Muzi Falconi 11 months ago

I reinstalled mactex and at least the path problem was solved.
now I get another error when processing the input file with AMC. The error now is "The deprecated command '\tl_to_lowercase:n' has been or will be removed on 2018-03-05. Use instead '\tex_lowercase:D '."

What is going on?
thanks

RE: Problems with Mac installation - Added by Marco Muzi Falconi 11 months ago

I fixed it; corrected line 1283 in automultiplechoice.sty

thanks
marco

RE: Problems with Mac installation - Added by Alexis Bienvenüe 11 months ago

This is fixed with git:bb4047db, maybe this needs the devel version from homebrew.

RE: Problems with Mac installation - Added by Maël Valais 11 months ago

Hi! Sorry for being late here.

Using Homebrew, you can install the devel version (ie the latest beta version available) using the --devel switch, and you can have both the stable and devel version installed and switch between them.

First, unlink it (it won't uninstall, only remove the current version from your PATH):

brew unlink auto-multiple-choice

Then, install the devel version (for now it is the version 1.4.0-beta1):

brew install maelvalais/amc/auto-multiple-choice --devel

To check what versions of amc are installed and switch back to them:

brew list --versions auto-multiple-choice
or 
brew info auto-multiple-choice

Let's imagine it returns

auto-multiple-choice 1.3.0.2199_1 1.4.0-beta1_1

If you want to be back to 1.3.0.2199_1:

brew switch auto-multiple-choice 1.3.0.2199_1

(1-6/6)