macports install fails

Added by Matthew Leingang about 1 year ago

Hi,

I was planning to switch to the development version, so I uninstalled my AMC with port uninstall. But then I discovered there was a new stable release much newer than mine, so I decided to go ahead and re-install the stable version.

But running port install auto-multiple-choice fails for me. Here is the relevant portion of the log file (I tried to attach the whole log file, but I think it's too big).

:info:build     embedded description / N=別紙答案用紙
:info:build   * extracting modeles/ja/scoring
:info:build     embedded description / N=採点基準
:info:build rm auto-multiple-choice.en.ext img_pdf/warning.pdf img_pdf/note.pdf auto-multiple-choice.ja.html auto-multiple-choice.fr.man auto-multiple-choice.fr.html auto-multiple-choice.ja.man auto-multiple-choice.ja.tex auto-multiple-choice.en.html img_pdf/important.pdf auto-multiple-choice.en.man auto-multiple-choice.ja.ext auto-multiple-choice.fr.ext
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/work/ac9013f9ddd7/doc'
:info:build make: *** [doc] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/work/ac9013f9ddd7'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/work/ac9013f9ddd7" && /usr/bin/make -j4 -w all
:info:build Exit code: 2
:error:build Failed to build auto-multiple-choice: command execution failed
:debug:build Error code: CHILDSTATUS 26330 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring" 
:debug:build     invoked from within
:debug:build "command_exec build" 
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname" 
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_auto-multiple-choice/auto-multiple-choice/main.log for details.

It seems that it's building Japanese documentation when it hits the error. I don't need that; so if I can work around by forcing an install it would be OK for me. Any help?

Best,
Matthew


Replies (1)

RE: macports install fails - Added by Matthew Leingang about 1 year ago

Never mind, I figured it out. The problem was that I didn't have the Linux Libertine and Dejavu fonts installed in /Library/Fonts. Once I installed those and retried, it worked fine.

(1-1/1)