New Installation on Ubuntu Gnome 17.04

Added by KYR GI over 2 years ago

I made a fresh AMC (1.3.0) installation on a fresh Ubuntu Gnome 17.04 installation.
I am facing problems with proper functioning. Although I can create a new project and compile it, I cannot re-open it. The pointer seems to working but never finish.

Kyriakos


Replies (8)

RE: New Installation on Ubuntu Gnome 17.04 - Added by Alexis Bienvenüe over 2 years ago

Can you try with debug mode on (from the Help menu) and post de resulting log file?

RE: New Installation on Ubuntu Gnome 17.04 - Added by KYR GI over 2 years ago

yes, I am attaching it.

KYR.

RE: New Installation on Ubuntu Gnome 17.04 - Added by Alexis Bienvenüe over 2 years ago

Can you post your source file?

RE: New Installation on Ubuntu Gnome 17.04 - Added by KYR GI over 2 years ago

I am using one of the examples as it is. I create a new project, use one of the templates, compile and detect layouts. I close AMC, reopen it, re-open same project but seems not to load the file.
I notice that Latex is not loaded upon opening AMC gui, as it used to be.
Kyr.

AMC-DEBUG-L07K9dmT.log - creation of a new project (87.3 kB)

AMC-DEBUG-MyAetYi2.log - re-opening the same project again, (24.3 kB)

RE: New Installation on Ubuntu Gnome 17.04 - Added by KYR GI over 2 years ago

Hi,
After some digging, I noticed that I have to delete "DOC-calage.xy" file for AMC to reload the project and update the documents.
I also noticed that although it updates the documents, the GUI says "No working documents". But documents are updated successfully and I can detect layouts.
Am I missing any essential package or is there a task that is not killed when AMC closes?

thank you in advance,
Kyr.

RE: New Installation on Ubuntu Gnome 17.04 - Added by Alexis Bienvenüe over 2 years ago

I'm sorry I can't reproduce your bug for now.
I installed a fresh Ubuntu 17.04 on a virtual host, installed AMC from Ubuntu repository, created a new project from a sample source file, updated documents and detected layouts. Then closed and opened AMC with this project, and all seems to go fine…
Maybe a localisation-related problem? Can you try lauching AMC with the following command?

LANG=C auto-multiple-choice

RE: New Installation on Ubuntu Gnome 17.04 - Added by Alexis Bienvenüe over 2 years ago

Also, can you try with the AMC version in the test PPA?

sudo add-apt-repository ppa:alexis.bienvenue/test
sudo apt-get update
sudo apt-get install auto-multiple-choice

RE: New Installation on Ubuntu Gnome 17.04 - Added by KYR GI over 2 years ago

Hi, the first solution did not work, but the second did! it must be a problem with the packages, because in the meantime I made a new installation of Ubuntu 16.10 and the fist thing I did is to install AMC and reboot with no updates at all, and it worked .
I tried to trace down the problem and can be with opencv-core 2.4 package that AMC is using, and the opencv-core 2.4v5 that ubuntu fetched during the updates.

thank you indeed for your help!

KYR.

(1-8/8)